spykee - help before i cry!!

36 posts / 0 new
Last post
EJW's picture
spykee - help before i cry!!

Hello, everyone. I hope that there is an expert out there who can help me... before I lose the will to keep trying.

 I bought my son a spykee for christmas and we have struggled ever since to get it to work.

 The main problems are:

  •  the network only seems to be available intermittently in the available network connections window (I am using Vista with SP1 installed). even when it is available connecting to it doesn't always work. About 50% of the time it works fine and I can then go on and connect to the spykee in the console etc. The rest of the time it says that it is waiting for users to connect to the network and then I can't see the robot to connect to it in the console. Hmmm...
  • When it does work, i can move it around and see through the camera etc but not for very long before it freezes. i then have to disconnect from the network, reconnect, connect to the spykee through the console etc before I can do anything
  • sometimes it not only freezes, but the console software entirely stops responding and I have to force-close it through task manager.

at the moment i am thinking this was the worst waste of £140 ever.

 please help :-)


GeoD's picture

I don't know how many of your problems are system specific. I have a Mac so I cannot advise on your Vista issues - but since no one was replying to you - and I didn't want you to cry :) - I thought I would offer the following in the hopes that it may help you in some way...

Ok. Below is a list of a few of the things I have found that seem to help...

I am running Mac Powerbook - OSX 10.5.6 - 1 gig ram - on Airport Express

1. Spykee WON'T connect to your network if it (the name of your network) is NOT one word, no spaces...
2. Video will lag severely over time if the console is not the ONLY program running at the time...
3. The 'name' of your Spykee should be one word, no spaces or special characters - same with the passwords...
4. Renewing your DHCP lease (in network prefs - TCP/IP) may be required to force a new I.P address (if it has gone blank)
5. Apparently Spykee can only handle WEP - I chose NONE (just easier)... (my network is out of range of potential piggy-backers)
6. The Good Quality video (fast network) is WAAAAY better, even in low light, than the Low Quality (slow) setting... I set my Mbps to 5.5 from 2.2 and it's lovely... (for a web cam)
7. For remote connections I have found Port-Mapping crucial - I selected the option in the console prefs and entered port 9050 - then in the AirPort Utility program - I selected Manual configure, then under the Advanced Menu button I selected Port Mapping. I then ADDED a new one and filled in the Public Port Number to 9000 and the Private Port Number to 9050. Then APPLY and allow AirPort to Update. Turn Spykee off, wait, then on - hope for your 3 beeps Smile
8. Sometimes I have had a "Spykee not Available" or "Internal Connection Error"... Even though he beeped 3 times at start-up - I could NOT connect remotely and would get those errors - but I COULD, for some reason (even with my open Internet connection and NOT the ad-hoc wi-fi selected) connect to it locally - with no such error. The solution seemed to be - turn off Spykee and wait a few moments. Turn it back on - wait for your 3 beeps - then try again. It would then work for me - no idea why... It seems if you can connect locally when you think it should be set to access remotely, you will get one of those errors... If it will NOT connect locally - you will probably then be ok for the remote... ughhh - I know...
9. The software seems to indicate the battery level is lower than it really is... Once conditioned a few times and left to fully charge - the battery seems to be fine for as much as a few hours of 'stand-by' (on but not connected to or moving) time...
10. The Auto-Park battery feature works best at about 3 feet from the charger base with it's back facing the charger... closer seems to make it less reliable...

I may think of some more to add later - but that's some of what I have found so far - and NOT from the official manuals etc. It was learned through lots of trial and error troubleshooting and from various posts on various forums... thought it might help to collect some of it in a more singular way...

Hope some of this helps. I woulda liked a list like this before I went totally grey... lol

Best of luck!

ED-209's picture

Hi all,
The first thing is These problems don't appear to be a fault with your SPYKE. What you ndee to determin is doe your robtoic pal have a constant connection. Check this by looking at your wireless network strength. If this is a case go buy yourself a wireless router (I use the DLINK ones and find they are quite good). This way you should have a constyant signal.

On second thoughts go buy the wireless router anyway its bound to fix your problems.

EJW's picture

Hi - thanks for your help, both.

The wireless signal (according to the number of bars showing on the connection on my PC) is either 4 bars or 0.

confusing. (But managing to hold it together and not cry)


dd's picture

I've got a similar problem to the original post, and the Meccano support is abysmal... 8 days and no response. WiFi strength is strong, I can directly connect to Spykee and can connect via a router, but regardless of how I connect within a minute of connecting (and usually before the connect sound has finished) Spykee freezes/reboots. I've tried several machines, XP, Vista, Win2k, and no luck... Anyone know an ETA for new firmware?

BTW, I love that Meccano is so behind this product that they've added this to the bottom of their FAQ:
"Meccano reserves the right to modify or suspend the free online support."


Spykeeman's picture

1. go to you list of networks in control pannel.
2. Make sure spykee beeps twice when you turn it on (if it doesnt hold restet button for 3 secs)
3. Connect to robot
4. Open spykee console
5. logon with admin
6. check details for everything

hope it helped

aperlik's picture

I hope your problem has been worked out but if not here is some advice from a rookie. I have my Spykee connected to a Vista computer. First of all are you trying to connect at the beginner level? If yes, be sure to turn off the connection to the internet. Then go back into the connections and look for Spykee. (Spykee has to be turned on.)

Connect to Spykee.

RebelTaz's picture

Well... I have the same problem. I am trying to set Spykee up in AdHoc mode for the first time using a laptop running Windows XP in VirtualBox under Linux. The Linux/Windows isn't my problem, though.

When I tell the laptop which network to connect to, I am presented with three choices - either of my two routers and SPYKEE******. I select the Spykee network, which shows 100% signal strength (the laptop is sitting 6 inches from the robot!) and it connects. Then the signal strength drops to 0%. Every once in a while it goes back to 100%, but more often than not, it's at 0%

I will try to see if my g/f's laptop will at least stay connected, but I can't use it to run the robot since she's running Win98..

Help? Ideas? Thanks....

*** EDIT ***
I just connected to the Spykee in AdHoc through my g/f's laptop and it seemed to keep the connection. But of course the freaking software won't run - I tried though!

RebelTaz's picture

I just wanted to say that I finally hooked up a USB wireless adapter I found laying around to my XP system and was able to connect via AdHoc to set him up. Then after a lot of messing around I was able to connect through the router locally and finally over a "simulated" internet connection. I'm going to take my laptop out with me tomorrow to see if it works in the wild!

I am going to have to do something about that freaking stationary camera though. I was thinking of using DTMF tones since you can send custom tones from the Sound FX. You can only add two, which is fine for up and down, but I had hoped to add pan left and right as well as an IR light source. That means I will need to be able to transmit at least five tones. Any ideas on how I might replace the factory sound effects, or are they hard coded into the robot itself?

Suzy's picture

We just got Spykee and it did not come with the CDRom to install the program on our computer. It also didn't have a manual included in the box. Some nice person posted a link to the manual and we are printing all 41 pages. Did any of you receive the CDRom program or am I missing something? HELP!!!

RebelTaz's picture

If you didn't get a CD with your Spukee, you can go to the web site and download it from there: http://www.spykeeworld.com/spykee/US/index.html under Step #3.

Meenzal's picture

I'm using a laptop with XP Sp3 and the builtin Broadcom network card to talk ad hoc, and connect to him from the net through a D-Link router (as above). My Spykee has no bad habits save for when it hits a wall it crawls up it and tips over. Even with the 200mw Broadcom card I can communicate with Spykee all over the house, even in the basement and outdoors for about 50 feet around where my computer is. Much farther with the higher powered D-Link router. I haven't suffered any of the various issues I've read others having --yet, anyway. So far it has been a lot of fun. I've used the audio a little, but it appears to work better as a remote mic than a remote 2-way audio device. But both do work for me. I figure I've had it long enough and it's time to change it. I'm thinking about a mod I saw where a guy took the camera and headlight out of the head and put it in the base. He took the robot body off completely and now has a Spykee that cannot tip over. If it falls on its back it still has traction when inverted. So you drive it right back into the wall or whatever knocked it over and it will right itself. There are also hacks for a pan and tilt head and movable arms.

If y'all want to see some of the hacks done on Spykee, go here: http://www.spykeemods.co.uk/ There's a lot of nifty things people have done with their Spykees.

McPee's picture


i can not charge my spykee.. my usb wlan adapter works with the ad hoc but the spykee dont react. if someone can help me please write a email to :
media-agentur-bellert @web.de

thank you

Lw's picture

Hi, I've got a different problem when I try to download the spykee console and I open it it says "The compressed (zipped) folder is invalid or corrupted"

Please help I have waiting ages to get this and when I get it it don't work "/

RebelTaz's picture

Where did you download the console software from? What operating system are you running?

Lw's picture

I downloaded it from spykee world and Ive got windows xp

RebelTaz's picture

Interesting.. I assume what you downloaded was like 600kb? The file downloading from their site is indeed corrupt. I have emailed them to let them know, but in the meantime, you can download the software from my server here:


I downloaded this from their site when I first got mine for just such an emergency. I never trust other peoples servers to remain active. Always have backup is my motto!

Hope this helps...

love70's picture

Dear Derek Tombrello,I had the same problem The compressed (zipped) folder is invalid or corrupt and I'm using windows vista and thanks to you helping someone previously with the same problem I downloaded the software from your server I couldn't get help from anyone here in Australia and was just about to return the robot so I just want to say thanks heaps your the best!!!!! I wonder how many people are having the same problem as the instructions say to download the console from www.spykeeworld.com

RebelTaz's picture

I am glad that I could help... SpykeeWorld replied to my email but they blamed the error on (from what I could make out) the decompression program used to unzip the file. they don't seem to understand that the problem is the file being downloaded isn't complete. Oh, well... I'll keep trying...

In the meantime, I'll add a link to my page to download the software from until they get their server fixed.

connect spykee
connect spykee's picture

how do u connect spykee to your home computer please help

Gnattycole's picture


You need a wireless network enabled computer. (Laptop typically) or a WiFi adaptor on your desktop PC. This allows you to connect to Spykee in what's known as ad hoc mode. Once Spykee is turned on, it will search for available networks. If it can't connect, it goes into "Ad Hoc" mode (2 "Gling-Gling" sounds), which enables you to search for it in the wireless network setup tab in Windows on the computer. (Search for available computers or networks and you should see it in there.)Once connected, you can enter setup and set the parameters for your local network etc. The instructions are fairly comprehensive if you follow them and if you don't have a set, you can download them from the Spykee website.
Hope the info helps, Good luck,



Jordan Gray
Jordan Gray's picture

The first thing I would check is your firewall/Internet filter. A lot of internet filters (K9, SafeEyes, CovenantEyes, etc.) can mess with these things. Try disabling them and then connectiong; if it doesn't work, well, IDK what the problem is.

markiz2010's picture

I hawe a spykee too,but i bothering ,that it possible to connect it?

markiz2010's picture

does spykee will work if you buy it from other hands?

jarrett's picture

is there a # to help me because this thing is ticking me off!

jason.b's picture

this thing looks awesome BUT i cant find my mac number or the robots name
its probably the fist in a long line of problems but i need help with this

Dale cooper
Dale cooper's picture

Why cant i change my admin password or set up a user name for remote connection? Whenever I try to add password and user as admin is says it incorrect, so I try my password it says incorrect new password. Really frustrating! Can someone please give me step by step instructions to connect remotely

Dale cooper
Dale cooper's picture

Why cant i change my admin password or set up a user name for remote connection? Whenever I try to add password and user as admin is says it incorrect, so I try my password it says incorrect new password. Really frustrating! Can someone please give me step by step instructions to connect remotely

Gnattycole's picture

Don't want to teach Granny to suck eggs here but you know it's case sensitive?

spock45's picture

Hi, when ever I enetr my info for my robot, it says its invalid!!! Please help!

DeanneTor's picture

We haven't used our Spykee for more than a year. Cat knocked it over and switch was left in on position. We rebuilt and charged it today but cannot get it to connect. Have two strong WIFI connections in the house (MAC and a 2Wire, only because I prefer my MAC Airport) Although Spykee seemed to charge OK, lights flashing while charging, lights flash when I take it off the charger but it doesn't make any sound and doesn't connect to WIFI. Tried pressing reset button but no such luck. My son, who has Cerebral Palsy and is in remission from Liver Cancer, is very disappointed. We used to control Spykee from his Macbook laptop but now neither my computer (Macbook Pro) nor his can see Spykee. Any troubleshooting help would be greatly appreciated.