Robosapien X website is out!!!

23 posts / 0 new
Last post
woowoorobotic 12
woowoorobotic 12's picture
Robosapien X website is out!!!

Hell to all,If you are seeing this message that means on the Wowwee website Robosapien X website is officially out. I been checking them Nowadays.(I don't know why but.....) Never mind here is the link.http://www.wowwee.com/en/products/toys/robots/robotics/robosapiens/robos...

nomad
nomad's picture

cant see it

woowoorobotic 12
woowoorobotic 12's picture
woowoorobotic 12
woowoorobotic 12's picture
woowoorobotic 12
woowoorobotic 12's picture

I can see it though.....

nomad
nomad's picture

yes i can open the link,but no infor about robo X

woowoorobotic 12
woowoorobotic 12's picture

really? I see it though...but maybe they're still updating info. So it messed up alot

nomad
nomad's picture

yes problably

woowoorobotic 12
woowoorobotic 12's picture

ok I think the website is out now

woowoorobotic 12
woowoorobotic 12's picture
nomad
nomad's picture

HI KEV.i see pic more but no by options.whits cell Phone does it use?

TehRSV2
TehRSV2's picture

I can see it. Hey Nomad it should work with any smartphone as long as there's an app for it.

3 years of RC

nomad
nomad's picture

i have an nokia x6

woowoorobotic 12
woowoorobotic 12's picture

oh....I used Pc and my phone is a Samsung Galaxy 2......

nomad
nomad's picture

i have an lg620gw too,you have it allreddy?

woowoorobotic 12
woowoorobotic 12's picture

what that phone you mean or the website?

nomad
nomad's picture

Phone yes

woowoorobotic 12
woowoorobotic 12's picture

yes it doesn't work for you? Maybe beause yours is an not supported phone

nomad
nomad's picture

the lg phone has firmwire 1.5 on it and has some android ,
pparts on

woowoorobotic 12
woowoorobotic 12's picture

I think they firmware needs to be above 2.5 or higher because my samsung is 4.0.

nomad
nomad's picture

yes ,i did some checking and least i need is 2.1 firmwire to do anything.

heyd
heyd's picture

awesome now i hope they do it with robopet rsv2 and rs media that would be great

TehRSV2
TehRSV2's picture

nomad said: i have an nokia x6

Were we talking about running the site or smartphones compatibale with RSX? If we were talking about running the site it should work with any phone that has internet borwsing.

3 years of RC