OUR NETWORK:TechLore Explore3DTV MyOpenRouter MediaSmart home TiVoCommunity See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 9639880.0
September 24, 2010 07:49 PM

Categories: WowWee Beta Firmware & Software

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

gerber

Member
Joined: 09/27/2007

Hi all

I am new to the RS Media. Well when I say new, I mean my son and daughter have both had RS media’s for 3 year. Only now since my daughters robot stop working and I asked for help from this forum have I learnt so much about the robot. It is only now that I can seeing so much potential and possibility of the RS Media Robots.

I really have to thank the members of the forum for giving me so much help, time and advice in trouble shooting the Broken robot and learn about the program aspect of the RS Media. A quick thankyou to  Jamie, FreddyA, Helibot, Vader and anybody else who has given me advise so far. (Currently the broken robot is still dead but I am really hopeful that I can repair it. The broken robot has now been named Frankenstien Monster as I am sure he needs a bolt of lightning to get him working again)

Anyway back the reason for this thread. My background is software development and I have many software and hardware idea I am going to develop in the near future to do with the RS Media. Some of which are:

RS media Musical instrument
RS media Auto dancing machine
RS media live video streamer
RS media robot Wars battle game.
RS media charging and Auto homing station
(I have many more but these are the more sane ideas I have had)

To start with I am just getting to grip with Linux and the command for the robot itself. I have however started working on my first project which I have called the RS Media Control station. Basically at the moment it is just a remote control to operate the RS media from the PC in realtime. This software will evolve over time and be that base station for all me software projects for the RS media.

Below is a screenshot of the “RS Media Control Station” software so far
 

Currently the software is quite crude and very basic as you control the robot in realtime by moving the scrollbar on the screen(but then again it did only take me half an hour to write)

Currently the software will only make the robots perform the basic movement but I will be adding all the other functions of the robot to the control panel. As it stands the software works quite well even though it is basic.

I will be getting rid of the scrollbar and to move the robot you will only have to drag the body part of the robot on the screen. I want to  try and make the robot image 3d but as I have never written anything using 3d graphic I’ll have to do some research first.

Current Software issues
Problem 1)
I have to switch off the robots vision and hearing from the RS medias remote control before I can control the robot from the software. However from previous thread that @Helibot and @Vader have sent I should be able to do this from within my software.

Problem 2) The other issue and more annoy I am have is that after a minute or 2 the robot go into a sleep mode then after about 5 minutes it powers off. FreddyA has advised me to look at the AUTONOMYV1 download to overcome this issue.

The software is fully working as it stand currently, but before its worth uploading, I think I need to do a lot more work to improve its functions and make it more use friendly.  I do however promise I will be upload it for everybody to play with in the near future and I will keep you all up to date with my progress.

Oh yes, I have just received my serial hack in the post an will be install it on the media board next week

All the best
Gerber

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

Discussion:    Add a Comment | Comments 31-45 of 257 | Latest Comment | « Previous 1 2 3 4 5 618 Next »

February 9, 2011 2:48 AM

You will need to start USB2TCP and NOT start TeraTerm (as it will block VSPE from using it) and then set up a comport to connect to 127.0.0.1:222.

Check out my site http://computersnmore.dyndns.org/

February 9, 2011 10:33 AM updated: February 9, 2011 10:35 AM

Hi

Vader > Do you close the serial port when your software exits?

Yes the port is close when the software is closed.

Curtainermaker, From you screen dump you have set com3 as your virtual port. You could try setting up a differnent virtual comport number.

One other thing it is important do everything in the following order:

1) switch on and plug ther robot into the PC with the USB cable
2) Switch off the robots vision and hearing
3) setup the VPSE and start the part
4) Start the USB2TCP
5) Start teraterm and connect to the virtual comport you set up in VPSE

I am sure you are doing the above from your screen dump on a previous post but I just wanted to check.

Before you went in to my software did you manage to control the robot in teraterm with the command I mentioned

/usr/bin/robot/scripts/MotorRel.sh 03 13 8

This command should move the robots arm. Doing this will check that you can comunicate with the robot. If it doesn't there is a problem with the comunication between the robot and the PC.

It took me a while to get it working like this and I think I was on MSN with Freddya for a few nights who guided me through it step by step before I managed to connect to the robot.

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

February 9, 2011 4:52 PM

Hi Gerber

Yes I Tried that command before i opened your program but nothing happened to the robot, just tried to go to sleep after a couple of minutes.

as you see from the page dump ":PAGE 2" it says No such file or directory

Curtainmaker

February 9, 2011 6:32 PM

Hi

I will try setting up the same way as you(With the standard usb cable). I'm a bit rust as I haven't connected like this since last september. You will need to give me a few days to try it. I only have windows 7 so can't test it on windows Vista but it should work the same.

Gerber

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

February 9, 2011 6:42 PM

Hi Gerber

Have tried again and done what you have suggested. I did get the arm to move with the command you said. But in your suggestion i had to do the following

1- Switch on robot and plug it into the comouter

2- switch off the Vision and hearing

3- Start USB2TCP

4- Start Teraterm pro

then I get the # Showing.  If I do it in the order you suggested the all I get in the teraterm is a blank screen and when I push the / or enter, text scrolls up and it shuts down.

I have tried the VPSE and that comes up but it makes no difference to any commands.

Also the robot has to be in the bondycon1 mode too.

Attached is the screen dump after the arm moved.

February 9, 2011 7:21 PM

Hi Curtainmaker

That's great news. Glad you got it working. I would defintely recomend doing the serial hack next, then the bluetooth mod. It's a lot easy to comunicate with the robot with these mods.

Gerber

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

February 13, 2011 2:16 PM

Hi helibot
I checked in the Options/ About to find out the version of my RS Media and it says: 09/05/2006b
Is this the version and is version 1 or 2.
I downloaded the RSMV2 Reload Files.
Unzipped then to the SD card and fired up the Bot. It started up as normal and didnt show the information on the screen as you have advised in the readme file.

I am trying to assume that the reason my bot wont work in Gerber Program is the it is still a V1 firmware.
What am i doing wrong.

Curtainmaker

February 13, 2011 2:36 PM

Hello Curtainmaker,

You have the same version as I did before I upgraded (Firmware V1). You do not need to upgrade to gain access to the root filesystem as you already are with the USB console.

DO NOT attempt to upgrade to V2 with the reload files, as it will not do anything at all, it will not reload because you aren't on the V2 firmware. To Gerber:
You should've given him the link to this: http://sourceforge.net/projects/rsmediadevkit/files/RSM%20Firmware/UpgradeRSM...

So download http://sourceforge.net/projects/rsmediadevkit/files/RSM%20Firmware/UpgradeRSM... and do the serial hack. Don't attempt to upgrade with USB Console as you will have no luck :-) When you have done the hack, follow the instructions carefully and upgrade your bot. If you flash the wrong file, your robot will be bricked and you will need alot of help to unbrick it.

Cheers,

Jamie Kugelmann

Check out my site http://computersnmore.dyndns.org/

February 13, 2011 3:10 PM

Hi Jamie

Thanks, I have deleted it off my SD Card

Cheers Curtainmaker

February 14, 2011 12:48 AM

Hello Curtainmaker,

I can give you help on the serial hack if you want to go ahead, you will need good soldering skills as the pads are quite small.

Let me know if you want to do the hack and upgrade your bot :)

Cheers,

Jamie Kugelmann

Check out my site http://computersnmore.dyndns.org/

February 14, 2011 3:06 AM

Hi Jamie
Thanks, Soldering skills arn't too bad, but i did download the site you sent me to. read up on it and it sounds quite intensive. Im not great on the programming thats why its easier for me to try and stick with the USB cable first before i try programming

Regards Curtainmaker

February 14, 2011 4:07 AM

hello every1 :),
well i tried everything 2 work the remote it doesnt work, here is what happens:
1- i open the usb2tcp
2- i open the hw virtual serial port
3- i open teraterm then the hw virtual indicates connected
4- i open the remote nothing happens altough when i take the command on the go box in the remote and put it manually in teraterm and click enter it moves the robot exactly like it supposes

Gerber command /usr/bin/robot/scripts/MotorRel.sh 03 13 8 also moves the robot hands, so what i wanna say here is that everything works but not from the remote it must be directly 2 teraterm also i can make the teraterm receive every act i do on the remote but still doesnt work this way and also when i do that ( move anything from the remote and it goes automatically 2 teraterm )i cannot copy and paste any commant on tera term anymore, it only receives from the remote but doesnt move the robot as well

i know my words may be confusing but if they r plz ask any question and i'll answer but plz try 2 find a solution with me coz its been a long while 4 me try 2 work it and never succeed
ps : the comport r right other wise it wouldnt move the robot even in the manual way i said
the live robot action is on i even try go but still no respond unless i copy the command from go and past it on teraterm

plz help

February 14, 2011 4:15 AM updated: February 14, 2011 4:21 AM

Hi Curtainmaker

There is no need to do the firmware upgrade at the moment as Jamie says. Also before you are able to do the firmware upgrade you will need the serial hack. The robot will work as it stands with the current connection you have and the current version of the firmware. The serial hack will make communicating with the robot a lot simpler as you don't need to use VPSE and USB2TCP. Even with the serial hack added there is still not necessary to upgrade your firmware and as jamie said if you make a mistake on the firmware upgrade you could end up with an expensive paper wait. If you do deside to upgrade the firmware make use to read the instruction first. The firmware upgrade isn't complex but you do need to do everthing in a set order. I upgraded my firmware to V2 about a month ago.

I have added the serial hack to 2 of my robots now and intend to add the serial hack to the other 2 I have. As I said on a previous post I had never solder before I did the serial hack. If you do deside to add the serial hack I would practise soldering first before attempting to solder on the robots board. As Jamie said the pads are quite small and you do need stead hands but with a little practice it is quite easy to solder. The serial hack only involves 3 wires being solder to the media board in the robot, so you will need to disassmble the robot.

I know how frustrating it must be for you at the moment as I had exactly the same problems last september when I was trying to communicate with my robot the same way.

Try the files I have sent you and if you are still having trouble I will set up the communication to the robot the same way you have you're and see if I have the same problem.

Cheers
Gerber

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

February 14, 2011 4:49 AM

Hi Donnie

I take it you are having the same problem as Curtainmaker and you are also using the standard usb connection not the serial hack?

I will set up my robot with the same connection as you Donnie and Curtainmaker and see if I have a problem

One question Donnie what windows version are you using?(Windows XP, Vista, 7)

Also to bothe Curtainmaker and Donnie what comport number are you using in VPSE?

You will need to giving me a few days to set up the communication with the robot with the standard USB cable as I haven't done it like this since last september but I will let you know how I get on.

Cheers
Gerber

Go to my website to download the latest version of the RS Media Control Station software www.TheMadRobot.talktalk.net

February 14, 2011 5:01 AM

hi Gerber

1st i wanna tnk u 4 doing all that effort 4 us :)

2nd i have 2 comp so i tried on xp and 7 but both same prob

i use hw virtual serial port( i tried vpse but still doesnt work ) and i tried com 1-2-3 and also another box written on port i use 222


ofcaurse take ur time and tnq very much Gerber :)

Discussion:    Add a Comment | Back to Top | Comments 31-45 of 257 | Latest Comment | « Previous 1 2 3 4 5 618 Next »

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window