Please help!!! RS Media Boots halfway and RSV2 voice trailing off

33 posts / 0 new
Last post
kindredd's picture
Please help!!! RS Media Boots halfway and RSV2 voice trailing off

Hi Guys,

Just to introduce myself I am a self confessed wowwee fan, having owned the robosapien, roboquad, roboraptor and femisapien.
I recently picked up a used/faulty RSV2 and RS Media for a song and was wondering if any of you might have encountered this problem before.

The RSV2, worked fine for about 10 minutes before I put it to dance mode and it went a wonky at the end of the dance. The music started to fade and sputter. After which I attempted to try a few different functions only to find that it stopped responding to my commands. After multiple on and offs, it finally triggered the self diagnostics sequence but the voice would trail off after a few seconds and it would stop responding. Taking the RSV@ apart, I saw the crumbling wire problem, which I assume is the cause of all these errors, including the dreaded bad motivator problem

The RS media is another story.

When I boot the RS Media, its eyes will pulse for about 30 seconds, the wow wee screen will show up and then it will say
"All systems go" or "Attention!" then. 789 in need of a recharge. At ease soldier." Then there is a humming sound that I believe indicates that it has shut down.

Is it similar to the wiring problem I am facing with the RSV2?

Any of you experienced similar situations before? I love thsese little bots and want to make them well again :(

kindredd's picture

OK, new discovery with regards to the rs media. I attempted to boot the bot while it was lying on its back. This time it went thru the introductory phrase but before it could continue with any movement the tilt sensor must have kicked in and it prompted that it was lying down. I then stood the RSmedia up very gently and walah! no auto off! I actually managed to get thru most of the media menu, take some pictures, record some audios, all the while the RS was motionless.

After this I switched to ARM mode. Moved both arms, no problem. The the moment I mad a motion to move the hips, the thing shut down!

This indicates to me there must be some wiring or perhaps transistor issue in the waist or neck section. Any ideas? Seems to only occur when it attempts to move the waist.Manually moving it while the robot is on does not impact it whatsover, does not reboot, but when instructed via the remote goes into the reboot stage again.

Using fresh new 1.5v alkalines, and have removed the casing checked the wiring and looks ok. What could be the problem? Please help, anyone

kindredd's picture

Can anyone out there please help me out? Spent the better part of the last 24 hours trying to analyse the problem with the RS media. Have removed most of the sockets to check if wither the waist of arm movements might have an impact. Yet to remove and investigate the legs. I do think its a problem at the motor board, not the brain board otherwise I would not be able to access the media menu, arms menu etc.

I have gone thru almost all the related links on this board, only 1 person has indicated that during the boot stage the robot would not boot properly in an upright position, only horizontally.

Freddy A, Santa Mat, Tika C anyone, please share your experience. Thanks in advanced

Helibot's picture

Hi Kindredd,
My guess would be that when the motors kick in to move the waist then it draws too much current , (which you battries cant deliver) the battery voltage then drops causing the bot to powerdown (because he thinks the batteries are low.)
So if my guess is right the next question is why is it drawing to much current when the waist motors are activated? You can try checking the motor board and see if any transistors are getting hot? (while hes powered up and idle , then also after trying a waist move)
Does the waist and leg joints move maunally OK? (maybe there is a mechanical problem blocking the leg moving).
You could try removing/disengaging the waist motors (and see of the motor spins freely with nothing to drive?)

The main board is probably OK (as you said). But there could be one of the motor drive circuits on the motor board could be damaged (I have this on one of my first RSMedia bot (I cant move the head left or right or it will reset - its been traced to one of the transistors on the main board but I havent tried replacing it -yet :-( )

One last comment - instead of lying him down and standing him up to get him to boot, just let him boot standing up and keep pressing stop key on the remote every one second. This will cause him to stop the intoduction moves as soon as it starts (and before he moves any motors).


TeamSlacker's picture

I just picked up a used V2, same type of problem. What I found was with all the wires in the harness's to the feet, the insulation is completey dry rotted. If you take off the 'chest' cover, you can see see the bundles of wires going thru the hips, they are wrapped in spiral wrap. Right were the wrap ended, I could see bare wires. When I took all the back and leg covers off, and started unwrapping that spiral wrap, all the insulation just crumbled in my hands. Time to solder up some new wire harness's.

kindredd's picture


thanks for the suggestions. will definitely try to detect any overheating transistors. Will try out the "stop" idea. What you said about the disengaging the waist motors sounds like a good idea, will do some tests there. Now I have another problem, the ribbon cable to the LCD screen has gone kaput. I think I unplugged it too many times without being careful and the connector(?) is damaged as in the contact points no longer have any metallic contacts :(. You live and learn I guess....Now the trouble is where can I find a replacement ribbon cable in Malaysia? Looks like its ebay I guess..

Team slacker,
Yeah, definately a confetti problem with the V2. I am in the middle of rewiring the entire leg section, basically a big replacement and soldering job. Lots of work and fun too. Hope I don't mess up anywhere, Will let you know once the little guy is up and running.

FreddyA's picture

Hello kindredd, good to see you are not afraid of the screwdriver. I'll start off with the ribbon. I had a broken ribbon in my RSM that casued it to not boot correctly or sometimes at all. and if it did boot, any movement would cause a freeze. I had to inspect each ribbon to find the break, I cut the ribbon and using a blade I scraped the insulation off leaving the exposed contacts about 1/4 inch. that worked for me and resolved all y booting problems. And I'll close off saying I sure hope its not something in the motor board and that it can be easily fixed. We need to keep the RSM breed alive, Big things are comming for them.

TeamSlaker, have fun rewireing your V2! I did.

kindredd's picture

Hi FreddyA,

Thanks for the feedback. I think I saw one of your earlier threads reporting this problem with the RSM. Was this also the big ribbon cable attached to the LCD monitor?

The broken ribbon connector is in this case, entirely my fault. Just was not careful enough when unplugging my RSM. Will do a bit more investigating to see if I can repair it, not sure if scraping off the insulation will provide me the contact points to attach to the "brain board".

PS, Thanks to ALL of you for your opinions and feedback. Without this forum I would not have had the courage to open up the robots and investigate th problems , let alone point a solder in the general direction of the robots.

FreddyA's picture

kindredd, at first glace I could not see the problem, it was only after powering on the robot and physically moving the wires around one by one is that I found the faulty cable. It was one of the ribbons from the head board that had a tiny break about 2 inches up. I also ruined my LCD ribbon contacts at the brain board end and had to cut it and carefully scrape off the insulation 1/4 inch up on that one too. It worked for me, and I did spend quite a bit of time looking for replacements. WowWee was no help and the local electronics store had ribbons but non that matched.

kindredd's picture

Hi Freddy,

Thanks again for the feedback. When you scraped the insulation off the LCD ribbon cable I assume you manage to expose the contact points that allowed it to fit with the connectors? May attempt to do this myself as none of the local stores here can supply me with that cable.

Update: I am halfway thru replacing the cables on my RSV2. Hope to get it done by this weekend and do a test run, so wish me luck!

right wires replaced

Right side; crumbling wires. Left side:New wires :)

Helibot's picture

Hi Kindredd,
Hope the repairs are going well... happy soldering :-)
(BTW I have done the 'scraping of insulation for ribbon cables' trick in the past (not for RSMedia though)- it works quite well...if you have a steady hand and pateince. A dremel type tool may work well??)

Hi Kindredd and Teamslacker,
Just out of interest, what do you think caused the crumbling insulation?
-Overheating (ie too much current, through too thin a wire?)
-Cheap wire? (just aging over time?)
-Movement? (caused because wires are continiously bent and straightened at a joint)

Is it all the wires or just a few?


TeamSlacker's picture

boy... the only wires I've seen get this bad is usually from heat. But considering all my 'leg' wires are like this including to the foot sensors (no high current), I would suspect something was flawed in that batch of insulation when it was manufactured. I haven't looked real close yet, but I think all the upper torso wires are fine.

FreddyA's picture

kindredd, just like Helibot said, it works quite well. in this picture you can see how far I scraped the ribbon. This one is from the head connections but the concept applies. I actually had to go as far as splicing a ribbon, it was a bitch but still making great contact.

Helibot, great to see you back in action. I wanted to comment also on the brittle plastic on some V2 wires. When I found this on one of my V2s I immediately thought the wire supplier basically made a bad plastic mix. However after closer inspection I found that some lengths of wire were still flexible. The flexible areas were the ones in the plastic spiral cover and the ends near the connector were the brittle parts, leading me to think that the exposed wire was maybe manipulated by the line workers with some reaction occurring over time. I say this because even on some wires without the spiral cover, the insulation was brittle near the connector housing. Regardless, its allot of work. Good times!


kindredd's picture

Hi FreddyA,
Thanks for the pictures! gives me much more confidence to attempt scraping off the insulation on my RS Medias ribbon cable.

Hi Helibot,

I'd concur with what FreddyA and TeamSlacker said. Most of my brittle wire issues were those that were connected from the feet to the main board.

The following wires/connectors were affected:-
Left leg
Right leg
D Battery power inputs
Left foot
right foot

These cables are all tied together with one or more power cables (the red and black ones attached to the D cells and AAA cells).

Foot sensor cables were not affected.

None of the cables attached to the head, upper body were affected.

My feeling is that its a combination of poor QC, bad quality materials coupled with overheating cables and friction from the movement caused the deterioration. I am not certain, but I would assume all the wiring came from the same batches, so the fact that only the lower body cables were affected indicate that the heat from the power cables is the culprit.

Please correct me if I am wrong :)

kindredd's picture

Well gents,

I completed re-wiring the RSV2, almost all the wires from the feet to torso. Insulated the key contact points with heat shrink tubes and electric cable tape and replaced the sockets. I put in the batteries and wallah! Life returns to the RSV2! Everything functions as normal, walking, arms, speech, vision :)

Then I try to turn the bot off....hmm its definitely off, no response to the remote but the eyes remain on ?! Checked the cables again, all look ok, turn it on and it does the flinch response (my hand was too close to the face). Damn strange. So now, I have afully functional RSV2 with one problem, cant fully shut down with the power off button!

Only way to turn the eyes off is to put it into sleep mode. However I noticed that even with that fix, the AAAs are still losing juice. I am sure I am missing something obvious. Anyone had this problem before? Dont think anything is short circuiting, no overheating batteries, just worried about the power draining too fast.

Update: After referring to the RSV2 schematics, I am wondering if it has anything to do with the red wire attached to the left foot and the 7 pin connector). Will have to investigate further.

Referring to the pin layout from another board-
"This connector connects to the board in the right foot. It carries the signals from the touch sensors and the forward tilt sensor, as well as 3 volts in from the left foot and 6 volts out for the brain. Red wire - 3v in, brown wire - 6v out."

kindredd's picture

Ok, some progress on the RSM tonight. Much thanks to Freddy A for the tips on scraping off the ribbon cable; my LCD monitor finally works. Managed to get it into Media mode and play some tunes! I seem to be having problems with the camera dunction but that may be a loose connection issue.

Still haven't identified why it keeps rebooting though. Not sure if Reflashing the bot would going to keep an eye out on Helibot's progress.

ON another note, I got me an original white (off white now) RSV2. Maybe I can transplant some parts to the RSM? Just an idea...

Chunkydragon's picture

I recently got an RS Media off Ebay that did not work. So far, I have him initialising, something he did not do before. The front LCD does not power up and I am unsure whether a cable is missing as I have never seen inside one, and whoever owned it before me had already took him apart.
Has anyone got a photo of the inside of the chest? I have one ribbon cable and what I presume is a mic cable? Should there be a power cable somewhere?
I ask on this thread as I see some pictures of inside lol!I am a newbie, and not sure whether to post a new thread or not :/
Thanks in advance :D

FreddyA's picture

Hello ChunkyDragon, let me welcome you to the forum.  Check the ends for missing contacts. My RSM lcd ribbon cable is very worn from reconnecting/disconnecting on a regular basis so that might be your LCD solution. However, the robot should boot fine even without he LCD connected. Does it boot to where you could use the controller? If not you might have more than just the LCD issues.

You have an awesome robot. Some TLC will get ip up and running then comes the fun.


Chunkydragon's picture


FreddyA said:

Hello ChunkyDragon, let me welcome you to the forum.  Check the ends for missing contacts. My RSM lcd ribbon cable is very worn from reconnecting/disconnecting on a regular basis so that might be your LCD solution. However, the robot should boot fine even without he LCD connected. Does it boot to where you could use the controller? If not you might have more than just the LCD issues. You have an awesome robot. Some TLC will get ip up and running then comes the fun. Freddy


Thank you Freddy!

He has a problem of rebooting, I only got him yesterday and am just begining looking through him for faults.The LCD was most obvious as the connectors are broken on either end from someone pulling them out I think. As I say, he is second hand and someone has barged through him before I could!

When he came to me he did nothing at all.

I read a lot on here before he came, so I tried a few things. He will boot to say *systems check* (and occasionally *booting personalities) as soon as he moves, he reboots.

He boots to that point mostly from a laying down position, then after he tells me he is horizontal, I can stand him up and he responds a little to the remote. First time he moves, he reboots.

I read through various pages here and that suggests a wiring fault or dry soldering somewhere?

When he is booted and just standing, he reponds in surprise when I flash my hand in his face, then he reboots, Always when he moves.

He can say *I Wowwee robot Rs media!* then reboots when he moves, gets no further than *media*.

I bought him as a pet project as I have always wanted one, but could never find one! Even broken he was awesome when I opened the box! So when he started to speak again, I was delighted!

I have never done this before and appreciate all help thrown my way! And this forum rocks, I doubt I could have gotten him to this point without it!

Thank you again!

Helibot's picture

Hey Chunkydragon, Welcome to the forum :-)
I guess that when he moves something is drawing too much current and causing a reset. But dont despair , it maybe only one motor or joint, so if you can isolate that then you may be able to use other parts of him (or fix the broken bit). Have you tried moving just some of his limbs to see if any particulr one causes a reset?
Try this:-
Bootup from lying down.
Stand him up
Press x button on remote (to turn off his eyes - so he wont flinch of more his head)
Now try each of the following (if he reboots, then reboot him like above and then try the next one)
- Hold L + R then press up or down. (both arms should move up & down)
- Hold L + R then press left and right. (both hands should twist left and right (I think?)
- Hold R and use left & right arrows on the right keypad (head should twist left & right)
- Hold R and use up & down arrows on the right keypad (head should move up and down)
- Hold L and use left direction arrows (Upper body should twist)
- Hold R and use left direction arrows (Hips and waist should move)

Hopefully you find some of the above movements work without causing reset.
If you are really lucky then only one of the above will cause reset and we can help you identify the mechanical or electrical problem.
If all of the above cause reset then you may have a more serious proble, :-( .you should also check that the batteries you are using are OK.

Chunkydragon's picture

Thank you Helibot! I appreciate the help!


I tried what you said, but I am thinking it may need to be videoed so you know what I am talking about.


So far this is what I have:


(L+R up and down) Left arm moves freely up and down, right arm barely moved but does attempt.


(L+R Left and right) Both hands twist left and right)


(R with left and right) Head moves to left then fingers click once, head moves to right, fingers click once. If fingers click twice in either direction he reboots.


(R with up and down) head moves up and down


(L and left direction arrows) Body twists freely


(R and left direction buttons) well, I have no idea what he SHOULD do but I doubt it is what he did! First attempt his right arm went backwards and his upper boddy twisted in same direction. He leaned backwards until his arm was on the floor then nothing. He MIGHT have ran out of oomfph, I need to get him a power supply. Then I rebooted him again and he seemed to do nothing with that command but reboot.


That is as far as I got with the final command as yet.


I ran through them all again and got the same results, batteries seemed fine then. Final command, nothing but a reboot.


Hope this shows some kind of known error! If a video is required to show exactly what is going on, I can get one made later. :D



Chunkydragon's picture


While trying the final command again, he suddenly started saying "Move away! Move away!" and walked backwards! Then rebooted. heh heh! His eyes were off at this time too, so no idea what made him do it.

But he certainly seems to do more than he initially seems to.

idrum289's picture

Chunkydragon said :"started saying "Move away! Move away!" and walked backwards!"

That's a new one. Mine's never done that. Hope you get him fixed Chunkydragon. Oh, and welcome to the forum!

Helibot's picture

Well you have got some good news there and some bad news!!
So far we can say:-
-Hand twisting motors and ccty are OK.
-Left arm movement looks OK.
-Right arm doesnt move correctly - could be a mechanical issue? (ie broken bit or gears slipping etc)
-Head can move OK in up/down and left right.
-Fingers dont close correctly when head moves.
-Waist moves OK.

My directions were wrong for this :
"Hold R and use left direction arrows (Hips and waist should move)"
This will cause him todo 'bulldozer' kicks - I think he put the left or right arm back , moves his legs, makes a noise then centers himself and sway right and left....So its using lots of motors and thats too much for your bot (at the moment!!) so he resets :-(.
Try this instead :-
"Hold L and use left/right arrows on the right keypad (He should lean left and right)"

So so far we have found two issues:-
1) His right arm doesn't move correctly.
2) his fingers dont close.
So for his arm , I guess its a mechanical issue. Can you hear any clicking or motor/gears spinning? You could try taking his chest plate off and seeing if you can see an issue. You could also try pulling his arm off (once the chest plate is off they can just pull off!!! In fact take them both off , cos if you take just one off then move his arms the other will most likely fall off too!!) Without the arm on see if the shoulder drive shaft spins OK.

For the fingers - the fingers are also driven by the motors that drive the head. When the head gets for the far left or right it should close the left or right fingers. It puts a lot of force on the motors todo this. You can try unhooking the big springs on the chest. This may allow the head to twist fully left and right (but the hands wont close anymore (I think?)). But try this to see if it avoids the reset.

Cheers for now

Chunkydragon's picture

Thanks guys! I will let you know how I go when I look at him tomorrow! :D

jimbobsquarepants's picture

Hi All I also have the RS and again having the problem with him stating the he is running low 789 ......I started taking it apart but it was to much for me and put it back together again .can anyine tell me where i can send this to be fixed

ian dovey
ian dovey's picture

hi there every one

i hope someone can help my son was given a rs media robot but it will do nothing but do the poping thing and say 789 needs recharge i have tried lying it down just says the same thing and shuts down if i stand it up it says the same thing i have replaced the batteries but i am still getting the same message

any help would much apreciated
thank you in advance
i dovey

Helibot's picture

Hi Ian,
First thing to check is have you checked both sets of batteries? There are 3 x D size batteries in each foot (to drive the motors) and 2 AA batteries in each foot (to drive the microcomputer). I know this sounds obvious, but a few people have asked the same question because they missed to change the AA batteries.


Shaun's picture

Try covering the wires with electrical tape, and reconnect the wires to the circuit board it came from. A sautering gun (i might've spelled it wrong) is the best tool to use to do so. Don't give up on your robot!

ian dovey
ian dovey's picture

Thank you for your responses

I have had some progress after taking the robot apart exept the lower legs i did not get to that part .the robot now boots up but now resets when doing the demo i am able to stop this and after that i have some control of the head and arms and the functions like taking pictures etc but when i try any main movement like walking it resets.
I would greatly appreciate any advice on solving this issue
I dovey (my son is over the moon that it works sort of and sends his thanks to you )or as he calls you those nice robot people

Helibot's picture

Hi Ian,
Its strange to have the first problem (always reporting low batteries) then have this stop and change to 'resets when moves' problem once you have pulled him apart abit. I wonder if this indicates he is drawing a lot of current (which can cause low battery message) and then when motors are used , it draws some more current and causes reset. Try checking to see if any components are getting hot or smelling , especially check on the motor board (the one with lots of big three leg transistors and silicon/glue on it.)

Other suggestions to try are mostly covered in page 1 of this thread.
I would try this order of things:
1) Look for burnt/damaged/hot transistors on the motor board.
2) Look for bad/crumbling insulation on the wires in the legs.
3) Try disengaging the motors (do this by unclipping the white rubber straps and sliding the motor out a bit). With no strain on the motor it may spin ok and not cause a reset. If you do it one at a time you may be able to identify one motor that causes the reset.
4) check the ribbon cables for breaks.
Good luck...let us know how you go!!