Setup Rovio on Windows Vista with 64 bits

23 posts / 0 new
Last post
santjust
santjust's picture
Setup Rovio on Windows Vista with 64 bits

Hello everyone!,

 I've just bought Rovio 3 days ago and I had a lot of problems to Setup on a 64bits PC with Windows Vista (on a HP touch smart PC)

 After reading a lot of info on internet, the conclusion is that there is no way to setup the Rovio with such a machine.

The big problem is that the software (even with the latest on the web of Rovio) it doesn't recognise the Rovio 1.0 USB, so just in case you have a 64 bits machine with Vista, don't try to cofigure it with the Software because there is no way (I've spent like 4 hours!!!9.

 Finally, I took my imac 24" and installed the Windows XP on it, and it worked perfectly and at the moment.

 I hope if someone read this post it will be helped ;-)

Pd: sorry if I have some english gramaticals errors...I'm from Spain!

roschler
roschler's picture

@santjust,

On 64-bit Vista, did you try to set up Rovio using "ad hoc" mode which does not require the use of the USB port?

-- roschler

santjust
santjust's picture

Hey!,

I tried to do it with the iMac but it was too late and i was too tired that finally I installed the windows XP on the iMac and then everything went well.

Sidekick
Sidekick's picture

If you use the installation software, it will not work on Vista 64bit because of the driver being 32bit.  I also tried it on Microsoft Virtual PC (which I have a 32bit XP installed) and I couldn't get it to take the USB.

However, roschler is correct.  If you reset the rovio (hard reset maybe?) or you just take it raw out of the box, you can configure it in ad hoc mode.  I use my Vista 64bit:

  1. go to Network - Network and Sharing center
  2. click on 'Connect to a network'
  3. Click on "ROVIO_WOWWEE" and press "Connect"

But here is the important thing that I found that I had to do, not sure when I did it though.

  1. Click on view status
  2. at the bottom, under "Activity", click on "Properties"
  3. Click on "Internet protocol version 4 (TCP/IP v4), then click  "Properties"
  4. Click "Use the following IP address"
  5. Change the IP address to 192.168.10.5
  6. Change the subnet mask to 255.255.255.0'
  7. Leave the default gateway blank
  8. click OK

Then you should be able to type in 192.168.10.18 in your browser, load the active x control, and have access to everything from there under the "settings" hyperlink.

Hope this helps!

denodan
denodan's picture

The only problem with Vista, is since you cannot use the USB to do a restore you are screwed, or in my case you would be.

I have been trying to get my Rovio on the WEB, but got it going perfectly through my Network.

Now I mucked around could not find Rovio at all, tried the Rovio finder and found no Rovio, came back with no IP address, so the only way was a restore using the USB cable.

Now if I had Vista I would have been stuffed as I don't see any other way to do a factory reset if you stuff your settings up?

denodan
denodan's picture

Just read somwhere there is a hard restore in Rovio?

S Powers
S Powers's picture

I was having trouble using my ROVIO with VISTA (Using IE Version 7). Could not disply Video or Hear Sound. I installed Google Chrome (A Free Browser) and used it instead, now I can access my Rovio, as intended. It worked for me it might work for you. If you do not like "Chrome" try "FireFox", instead. You still can still use IE7 for everything else. Installing another browser does not stop you from using, whichever browser you want. On my XP machine, I refused to install IE7 and kept IE6. Everythig works fine with IE6, on that computer.

dingo rovio
dingo rovio's picture

i would be happy to see this 300$ nightmare do anything,I have loaded all the new programs and it flashes orange light for about 30 sec then quits.seems it cant find a network im useing alltell phone for link to get on the net and its a wireless conection can i run rovio thru that

manny
manny's picture

nesecito alluda rovio tengo w vista y no puedo intalarlo

santjust
santjust's picture

It seems that on 64 bits doesn't work :-(

matrix2004
matrix2004's picture

Any update? I just got it and can't install drivers.

rdjohnso
rdjohnso's picture

Runnine Windows 7 on new Dell XPS machine...... cant even get the installer to work... any assistance would be parreciated...
I am a computer junkie and typically know what I am doing so I do understnad alot of this lingo so advanced processes are welcomed.

Thanks

Ron

roschler
roschler's picture

Did you give ad hoc mode a try? Look user manual for "ad hoc" installation.

-- roschler

matrix2004
matrix2004's picture

roschler said:
Did you give ad hoc mode a try? Look user manual for "ad hoc" installation.
-- roschler

I did but when i go into Network and sharing, it doesn't let me add another connection or maybe i don't know how to?

 

Which option do i choose?

Gmaster0302
Gmaster0302's picture

Hi,

Just wanted to comment. I have vista 64, and it did not recognize my rovio when i did the setup. I have VMWARE virtual PC installed in my vista. So I uploaded Apple OSx 10.6.2 as a virtual pc, and once loaded, downloaded the install pack from myrovio.com for MAC, installed it within the MAC OS, it then recognized my rovio, then my rovio found my wifi which was locked with WEP, so i put in my password, and wala it worked. Now I go back to vista type in my local ip address 192.168.2.2 and it worked... Also Port forwarding got setup automaticaly, and it gave me an IP of 77.22.1*(**&* and so now i could connect to my rovio from anywhere in the world. Including my iphone. I

matrix2004
matrix2004's picture

Sidekick said:
If you use the installation software, it will not work on Vista 64bit because of the driver being 32bit.  I also tried it on Microsoft Virtual PC (which I have a 32bit XP installed) and I couldn't get it to take the USB.
However, roschler is correct.  If you reset the rovio (hard reset maybe?) or you just take it raw out of the box, you can configure it in ad hoc mode.  I use my Vista 64bit:

  1. go to Network - Network and Sharing center
  2. click on 'Connect to a network'
  3. Click on "ROVIO_WOWWEE" and press "Connect"

But here is the important thing that I found that I had to do, not sure when I did it though.

  1. Click on view status
  2. at the bottom, under "Activity", click on "Properties"
  3. Click on "Internet protocol version 4 (TCP/IP v4), then click  "Properties"
  4. Click "Use the following IP address"
  5. Change the IP address to 192.168.10.5
  6. Change the subnet mask to 255.255.255.0'
  7. Leave the default gateway blank
  8. click OK

Then you should be able to type in 192.168.10.18 in your browser, load the active x control, and have access to everything from there under the "settings" hyperlink.
Hope this helps!

So can this be done with my wifi router or does it have to be with a pc wifi adapter?

wreker
wreker's picture

This is done with the PC wifi.
What you are doing is joining a peer-to-peer wifi network.
Kind of like using a cross-over cable between 2 computers.
There is no DHCP server so each computer has to be Manually configured on the same (subnet) IP range.
The default IP for the rovio is the 192.168.10.18 and it is Static.
So you change your PC wifi IP address to 192.168.10.10
Then join the rovio_wowee wifi network.
Now you can connect to your rovio at http://192.168.10.18 and configure your rovio with your Real Wifi Router network info; wireless network name, password, etc.
Then reconfigure your PC back to your normal settings.
Now everyone should be on the same wireless network.

matrix2004
matrix2004's picture

Ok. so it seems my Rovio is not detected and i can't connect to it in AD Hoc mode. Any suggestions?

Boykiko
Boykiko's picture

how to fix my rovio?

i can see it on my available wireless and when i connect it and change its ip with the manual givin ip...still i cant view it on http://192.168.10.18....

im using windows 7 64bit.... im not really good on networking wifi....

Hoping for a good reply here...

Thanks...

Boykiko
Boykiko's picture

how to fix my rovio?

i can see it on my available wireless and when i connect it and change its ip with the manual givin ip...still i cant view it on http://192.168.10.18....

im using windows 7 64bit.... im not really good on networking wifi....

Hoping for a good reply here...

Thanks...

matrix2004
matrix2004's picture

When you find out, let me know. Still haven't set it up. This is year 3.

Boykiko
Boykiko's picture

yeah i just bought it last December.... i really had a bad time with it installing on 64 bit.... which is not compatible with it and needs only xp...

christopher mckay
christopher mckay's picture

Hi I was running into trouble one my 64bit 8gb ram win8 PC. I used my dad's 32bit winXP PC and it worked great. NOTE: I did have to select the option to manually install firmware as it couldn't find it online!