New Rovio Beta Firmware Available - Feedback Needed!

254 posts / 0 new
Last post
Peter Redmer
Peter Redmer's picture
New Rovio Beta Firmware Available - Feedback Needed!

Hello everyone,

We're excited to announce that WowWee is looking for additional beta testers for the newest version of the Rovio firmware, 5.00b7.

You can snag this version of the firmware in our downloads area by clicking here.

Once you get a chance to test the new firmware, please come back to this thread and post your feedback for WowWee.  We'd love to hear how the installation process goes and all the details of how the new firmware works for you.

Looking forward to the results and your contributions to making Rovio the best it can be, happy testing!

Mark4's picture

I have just uploaded the new firmware to my rovio just a few seconds ago, upgrade seemed successful. Some nice new features in the settings panel. New status symbol on the status bar looks good. Will check stability over the coming days. Video is still dimm however :(.

Mark4's picture

Rather than create another reply I will edit this one to include some more information.

So far I have experienced the following with the new beta firmware.

Rovio Fixes:

Taking photos and e-mailing them in Firefox no longer results in a browser crash.

2 way audio works in Internet Explorer on ports other than

Signal Bar labels now show correct percentages.

Docking improved, no more firmware freezing occurs on docking / rovio lowers camera boom quicker.

Closing the tab in Firefox or browsing off Rovio's page now closes the JPEG stream correctly and Rovio closes the connection properly

Rovio new Issues:

An issue with the new verify Internet access settings and uPnP settings sometimes results in no active X feed constant loading). I still havent found the exact settings or cause of this problem however accessing the external ip address rather than the internal (LAN IP) address will sometimes work.

These are the experiences I have seen so far I will add more to the list in another reply if they crop up.

Also do we have a changelog available?


cowboyctx's picture

I upload firmware and here is what I found so far. When driving the Rovio it hesitats or pauses almost like a pulse(I have not have this problem before). It also seems the record path works better. The rest is pretty much in-lie with Mark's findings.

Will add if I find more issues.

SSA's picture


Well just installed the new firmware. It works fine when on the internal and external network so far.No pauses or anything. I have done the following:

01) Used a dynamic domain name(DYNDNS)
02) Opened 2 ports manually on my router 80 and 554.(Linksys 350n)
03) Given Rovio a manual IP.

In the internet access section ive click manually open ports and put 80 in the start port and left my internal ip blank as i am using dynamic domain.


Fraggboy's picture

Mark4 said: ...Also do we have a changelog available? Cheers

There is a full changelog available on the download page.  Just scroll down.

Mark4's picture

Thanks for that fraggboy I was downloading the firmware so quickly I missed that the page contained a changelog, need to clean my glasses!


SmokNyrEyz's picture

wish i could say i had success - after the update i could no longer connect to rovio - i did a restore, and now i can't even get setup to run to get me going again - i should have left this one alone

Mark4's picture

SmokNyrEyz, when updating the firmware all of Rovios settings are reset to a factory default. Have you tried connecting to Rovio in Ad-Hoc mode first and then changing its network settings to infrastructure?

SmokNyrEyz's picture

Mark4 said:

SmokNyrEyz, when updating the firmware all of Rovios settings are reset to a factory default. Have you tried connecting to Rovio in Ad-Hoc mode first and then changing its network settings to infrastructure?

im using the setup software rather than trying to do it manually

travfar's picture

OMG!!!! You can reset your rovio without using an external machine now. That alone is worth it. I can break down my XP machine back into parts.

SmokNyrEyz's picture it working again - not sure what caused the problem - whew - that was scary

epyon's picture

Losing the dependency on port 80 for two way audio is a BIG fix for those of us with ISP's that block it.

I'll be giving this a go over the weekend.

RemoteMike's picture

OK (deep breath)

I'm using a MacBook Air (first gen) with OS X 10.5.6
Linksys WRT350N

The main issue I see is that after less than a minute of viewing Rovio's video (QT or MJPEG) the MacBook loses the network connection. Unusually, I can't ping anything on my local network or the Internet after the disruption even though I show full WiFi signal strength on the MacBook. If I toggle Airport (MacBook WiFi) off and then on again the network returns at full signal strength (as one would expect) and Ping results return from both Rovio and the Internet. I ran two open command windows with constant Ping to both Rovio and external (Internet) IP's so I could monitor when network continuity (as indicated by ping responses) was lost and restored.

Using Safari, I noticed video defaulted to MJPEG. I switched to QT. Using QT seemed to accelerate network drop-out - so much so that I had *real* problems toggling the Airport WiFi adapter off/on again/reloading page/accessing settings/changing settings/saving settings again before I lost connectivity. After 10 minutes I finally did the tasks fast enough and switched things back to MJPEG. However, the problem with network continuity remained, though disruption would occur at the rate initially observed with MJPEG. On a positive note, I was able to hear audio with video while using QT, though audio was not synchronous with video - lagging by about 4 seconds.

Using Firefox, I noticed I did not have an option for QT and video defaulted to MJPEG (as expected). I would lose network connectivity at about the same rate as with Safari using MJPEG. After loss of connectivity, recovery also required toggling the Airport WiFi adapter off and on again. I noted that using the keyboard yaw commands in Firefox resulted in a continued command state, even after the key (Q or E) was released. This made Rovio spin until I used the mouse key to hit "stop" in the web UI. Command keys in Safari operated as expected.

So, I see extreme problems here with basic network connectivity. Apparently something with Rovio network comms or the web UI is locking up the MacBook's WiFi adapter or network stack - causing complete loss of the network to the laptop. Not only could I not access Rovio, but I also lost all network communication with other devices and the Internet until the MacBook WiFi adapter was toggled off and on again.

I can't recommend this for anything other than testing, and only if you have plenty of time to spend playing with settings and trying to recover control, load the previous firmware and then reconfigure again.

Message to WowWee engineers - It looks like you're headed in the right direction with QT features, but some serious problems exist.


roviouser's picture

There is a problem when accessing the rovio webpage as guest using the 5.00b7 firmware.
Using Safari on Mac OS X, set the video to Quicktime.

Now access the Rovio web page with a user with guest access. A dialog box keeps popping up asking to type in a user with administrative access.

dafuser's picture

Well I installed the new beta firmware. Everything seems to be working well so far. I can access Rovio on my internal network and from the Internet using my DynDns domain URL.

I have a couple of Dynamic Domain Name(DynDns) domains which can reach my Rovio.
I have opened 3 ports manually on Airport Extreme (TCP Ports 80, 564, and 8168)

I changed the networks settings to "manually open ports".

Under Internet Access on the Rovio network setup, Rovio was able to obtain my Internet IP without problems, but puts a question mark on the screen for system status and says "Unable to verify internet access to your Rovio". Clicking on the question mark opens a window which says:

"Rovio was unable to verify that it can be accessed over the internet on the following IP address First, ensure your router is connected to the internet and working. Try selecting another start port in the network settings tab as some ports might be blocked by your internet service provider."

I can reach my Rovio from the Internet without any problems, so I don't know why Rovio displays the various error messages. What is port 8168 being used for?


Josh S
Josh S's picture

Regarding the active-x issue we are looking into it. Please let us know as soon as you have exact settings.

Noted, thanks! Bug fixed in v5.00b8… will be released very soon =)

Wow sounds like you are having some major wifi issues! Honestly, sounds like something else is on the same WiFi channel e.g. your neighbor is using a cordless phone, another WiFi router, etc. Does it do this with all versions or just v5.00b7?

First I would try changing the channel on your WiFi router. If that doesn’t help I would verify it is Rovio’s issue by continuously streaming video from utube or CNN.

We have defaulted the video to MJPEG for the moment because as you noted there is a 1-4 second delay on the audio and we are fixing some NAT related issues with the Quicktime stream over the internet. The QT option was not included in Firefox yet because the Quicktime object in FF doesn’t seem to support streaming RTSP feeds.


Mark4's picture

Josh, after playing arround with the settings again heres what I found.

Sometimes when applying a change of settings to the Internet Access in the network settings menu with Internet Explorer the settings will not correctly update on Rovio and it will crash the firmware requiring a powering down and up again I also noticed after doing this that the Verify Internet Access check box and Include in status bar check box become un-ticked on their own. However this does not seem to occur in Firefox when changing these settings for some strange reason.

I have now fixed not being able to access the active-x stream on the local ip address. It seems that having anything other than the following settings under the Internet Access Settings will result in no active-x stream locally.

Automatically open ports using uPnP
Start port: 8168
Internet Ip: blanked out

I am using port 8888 for the web interface on Rovio and DHCP to automatically obtain an IP address for Rovio from my router.

Even after having these settings work for local active-x streaming they result in Rovion being unable to determine the internet access and result in an orange question mark on the status bar.

Using manual ports set to 8888 (the same as the web interface) will fix this and Rovio can verify its internet access but again there is no local active-x streaming in IE.

As stated previously Firefox has no issues with M-JPEG streaming at this time.

One further problem that has cropped up is that of the network performance generally.

I was previously using the 4.09beta off wowwee's website, I had no trouble in driving Rovio arround, video would remain stable in Firefox and Internet Explorer and the web interface will show a good wi-fi signal strength pretty much everywhere.

However since using 5.00b7 the network performance is not very good. Video streaming stops and starts as well as the audio feed and after being connected for a few minutes the video incurrs a big delay of 3 seconds or so of responding to a driving command. The wi-fi signal strength is approximately 1 bar lower everywhere when compared to the strength in v4.09b which to me seems very odd.

Restoring the firmware to V4.09b resolves all this and network performance is once again very good.

I cant help but think the new verify internet access feature is causing this as sometimes when driving Rovio arround the LED indicator on the power switch will cycle between green, orange and red even when I am connected and using it.

Hope this helps


Update: When trying to disable the Verify Internet Access feature it will not remain disabled. The tick box will stay un-ticked once you have applied the new setting, but as soon as you disconnect and re-connect to Rovio it re-ticks itself.

dCon0ne's picture

OK I upgraded to the new Firmware (5.00b7) and now when I try to re-setup Rovio.
  I get as far as putting the Admin Username & Password.  Then I lost connection??????

I get the above error using Static 0r Dynamic IP address....

SSA's picture

Had a similar problem using 3.97 but i tried a few times and it worked.Just manually restart Rovio and plug in the usb cable in ure pc and rovio when its still trying to connect to the network and follow the on screen instructions. Thats how mine was connected.

dCon0ne's picture

Well I finally gained access to the New Frimware setup. Had to do it via
Ad-Hoc Wireless.

Ramzez's picture

Hi there all

I just got my Rovio on the 17th. I have been playing with my network to get it to work ever since. Any ways thats not what I will discuss here.

I just upgraded firmware but it didn't go without a hitch.

First of all the screen froze after the time countdown went to zero. When I noticed that the power light on rovio was totally off (blue lights where on)even if the power was on. This was happening with an older laptop with IE 6.0. I connected to Rovio and in the system settings the firmware version was blank. So I decided to "Restore Default Settings". Once that over I could no longer connect to Rovio.

So I decided to install the Rovio setup software on my Vista machine and used the software to restore. That worked more or less. After some fidling (can't remember what I did) I was able to connect to Rovio via the instalation software and make it work again. When I went to the System settings the firmware was updated.... go figure.


Is there some kind of more detailed documentation an the new additions with the new Firmware? Specifically the Network Settings.

I am not a newbie to setting up router but I can't figure out how to connect to Rovio via outside network. I can from inside.

Can anyone help?


Leebo's picture

>... I can't figure out how to connect to Rovio via outside network. I can from inside.

You'll probably need to consult your ISP's gateway documentation...assuming your ISP has provided you a DSL or Cable modem, you'll need to get into the setup program and see how to forward packets from the internet to the appropriate IP address and ports used by the Rovio on your network (Ports 80 and 554).

To access the Rovio from outside, you just need to use your web browser to hit the IP address of your gateway. Assuming your ports are set up correctly, you would then be presented with the Rovio login.

Remember that the IP address of your gateway may change from time to time.

dCon0ne's picture

>... I can't figure out how to connect to Rovio via outside network. I can from inside.

SEARCH this Forum, there several topics about PORT FORWARDING to Rovio's IP Address. Also get yourself a Free :-) Dynamic DNS account from This will make it easier to connect to your Rovio from the Internet.

RemoteMike's picture


I did more testing today. I found the network problems only occur after enabling QT under 5.00b7 on OS X 10.5.6. I *do not* see this problem under 5.00b7 using MJPEG or with previous Rovio firmware versions.

I have aprox 10 other wireless devices on the network not connected to Rovio that do not appear to be effected by this issue.

I use the following network topology:

MacBook Air => Trendnet TEW-652BRP => Linksys RLV200 => Linksys WRT350N (G mode) -> Rovio
and alternately
MacBook Air => Linksys WRT350N (G mode) -> Rovio

I see the same results with both configurations.

The network only becomes unresponsive when the MacBook Air is connected to Rovio's Web UI configured to display QT video - using both Safari and Firefox.

Other devices on the network not connected to Rovio continue to operate without interruption.

This leads me to believe there is something in the QT support that effects the internal OS X / Safari / QT architecture and interrupts the OS X IP network stack.

Please also note the issue reported with yaw command latching under OS X / Firefox which results in a spinning Rovio remains, and in my opinion cannot be explained by a possible network issue.

Thanks in advance for the time you'll spend considering this.



SoloconDeus's picture

Installed the new firmware 5.00b7, and everything seems to be working fine. Except I am getting this annoy noise out of rovio's speaker. If I play with the volume (make it go up or down) then it stops for a bit. Any ideas. I will do some more testing in the morning, spent most of the night tring to figure out why the nosie was coming out of the speaker even with PC mic volume turned down.

Giobatta's picture

Everythings works fine, the new interface is better.
And Quicktime is a very nice feature, I hope this will support audio for OSX users!!!!
(actually is not working for me, so I cant judge, I just see the usual big "Q", some hints?)

I just have two problem:

- cpu is going crazy, I'm using a C2D (iMac) with Safari 3.2.1 and now the Rovio interface drains the 80% of both the cores (computer stuck)

-auto mapping port, Rovio seems unable to map ports
My configuration is Rovio (fixed ip) ---> Airport Extreme ---> Linksys Modem
the modem handles uPnP and it is on
it also handles redirection to the fixed Rovio IP address
(the router its just in pass-thru/bridge mode)
However. if it isnt related to Quicktime (not working) isnt a big flaw, I prefer to manually
map ports in the Modem, how ports needs Quicktime?

Anyway,a warm thanks for the update.

Fred_'s picture

cowboyctx said:
I upload firmware and here is what I found so far. When driving the Rovio it hesitats or pauses almost like a pulse(I have not have this problem before). It also seems the record path works better. The rest is pretty much in-lie with Mark's findings.
Will add if I find more issues.


Hi all,


I have the same problem.

With 4.02 and 4.09, driving is very "fluid". With last firmware,  Rovio seems freeze, hesitates or pauses when moving.

I switch back to 4.09 and everything is ok again.

Giobatta's picture

btw I noticed the framerate is faster or today my provider is not under the usual massive DOS attack?
I can sustain 640 resolution without any problem....

again thanks to your effort making Rovio a better product every day.

PostScriptum: please HEEEEELP about Quicktime, is not working and on a Mac is a bit ridiculous :D
Can I map the QT port manually? I really want to listen audio ....

Fraggboy's picture


If you see the "Q" only, that generally means that Quicktime isn't installed or properly associated.

Giobatta's picture

Fraggboy said:


If you see the "Q" only, that generally means that Quicktime isn't installed or properly associated.

Fraggboy, no offense but this is impossible, QT is THE default media player for any Mac, is installed by default and automatically updated by Apple (just like WMP on Windows).

I see the big Q with the bar scrolling left and right, like it is loading something, but never happens also after several minutes :(