Rovio battery

318 posts / 0 new
Last post
denodan
denodan's picture
ET said: OK, one more thing

ET said: OK, one more thing discovered - when sitting in the dock for a while the rovio stops blinking as fully charged, but the battery indicator shows 3 bars only. It shows full bars only when charged overnight. Anyway even overnight charging gives me 15-20 minutes to play with rovio from full to 2-3 bars and then battery dies unexpectedly. I have a ticket from the customer support, let's see what solution will be.

My replacement battery was the same, now its gone from 10 mins max to 80 mins max. Mine also stopped blinking, as though fully charged. Take it off, put it on the dock again, wait till it stops blinking and repeat for 2-3 hours, also let Rovio fully discharge till it dies, then recharge. If you do these things long enough it will fix the battery. It did with mine anyway?

denodan
denodan's picture
Aeroworks said: I have been

Aeroworks said: I have been using my Rovio for a few days now and the battery issue is driving me crazy. Ill dock it and it will charge for a little while, then it will go to roaming and kill itself. I have sat a heavy object ontop of rovio while charging to ensure the contacts are touching and i get the same result! what is the deal with this thing? I am contacting support about this today. **Update** I Did some testing and it seems it will only charge for 14 minutes before going to roaming mode. I would loginto rovio and press the back button to get it to charge. Then start the timer. 14 minutes later it will go back to roaming mode. I did this 4 times and each time about 14 minutes before it stopped charging. First glance you may think the battery is fully charged and it stoped because of this.. but i started on a completely dead battery (rovio shut itself down due to low battery). I wonder if this is a software problem.. seems like the battery is giving off false voltages and the rovio thinks its fully charged and disconnects. I wish they would release some kind of statement about it, as it is not even close to being an isolated problem.

Check my post about the battery discovery. I have a techque which will most likely fix your battery? It fixed mine, as mine went from 10 mins to now 80 mins on full charge. I managed to fix the memory effect.

 

I have thought, since the batteries are made in China, then don't hold charge long, get to low a charge and seems to stuff up the memory of the battery, so you have to trick it back again. I managed to do this.

cowboyctx
cowboyctx's picture
If you don't have time to re

If you don't have time to re-dock your Rovio. Try using Rovio Commander, it has a charge mode that will re-dock it for you.

Robi
Robi's picture
Hi,

Hi,

I bought my Rovio last November and I have never got a problem with the battery. I always can drive my Rovio around for 1 hour non-stop, or leave it undocked for many hours and doing several short walks (5/10 minutes each); you know: go out of the dock on the morning, go to the kitchen, park it there, a while after go to other place and park it again, and so on until the afternoon and then dock the Rovio when I get the "low battery" alert.

Well, that is my history in Spain, but on January I travelled to our house in Ireland and installed Rovio there. The first surprise was a sudden and big shortage in the timelife of battery. Then I did a full discharge of the battery (Rovio turned off itself after almost a complete day undocked) and charged it again around 12 hours. After that operation the battery life returned to "normal" level (more or less) and I drive Rovio each day from Madrid (Rovio is "living" in Ireland) without problems.

To sum up, my Rovio is docked more than 12 hours everyday and "working" several hours a day (short walks). I always leave it undocked (but very near to the dock) after I use it, that way it returns by itself to the dock when the battery is really low.

The other point is I think in Spain we have "better" electricity service than in Ireland (you know: no peaks, stability...). Also, in our Spanish home we have a "three-phase 220v" installation not the usual "domestic single-phase 220v" that we have in Ireland. Is it important? Who knows?

Anyway I am sure Rovio needs a long charge period (at least overnight) to work properly. Also, I think it is better to discharge it almost completely (leave it to dock itself).

chris75
chris75's picture
Definitely there is something

Definitely there is something wrong with firmware but hardware may not be totally ok too.

One problem I found is that Rovio 'sees' different battery levels when docked/undocked. Batt level (via API) under 110 will cause Rovio to go home to charge, level below 106 will cause it to shut down.
When Rovio is low it will go to dock, level is let say 110, and when docked it will measure immediately 104 or less, charger (power issue) will not make the level go up fast enough to go above 106 (safe level) and Rovio will shutdown after 15-30 secs.

I bought 5 good NIMH elements (4600mAh vs 3000mAh) and replaced the original pack, things are much better. The Rovio shutdown after redocking syndrom seems apparently gone.

I'm still experimenting to see if I get more autonomy etc....

If firwmare was smart enough to give a longer grace delay for charging before shutting everything, I think it would greatly improve things.

So from what I see :
* Firmware needs smarter charging / redocking code (may be to compensate a HW issue)
* Charger module needs to be more powerfull
* Charger needs better end of charge detection, looks like it says fully charged at a fraction of real capacity.

Chris

Daniel 4000
Daniel 4000's picture
My rovio would only operate

My rovio would only operate off of the base for 10 min before saying charge is low.It would only charge for a few min before reading a full charge. I bought a new 9 Volt 1700 mah charging cube for 11 dollars on E-Bay. Now it charges and the charging lights blink for almost 2 hours before having a full charge. Now it works great!

Sparrow
Sparrow's picture
Same problem here. Received

Same problem here. Received Rovio about 10 days ago...blue battery wouln't charge it would just last for about 20 seconds...i then purchased a new charger from radioshack 9 v 2000 mah, lefted to charge for about 12 hrs ... Nothing happened still wouldn't hold a charge.... After this i went with a baja 6v battery 3000mah , radioshack charger... After 1 hr of charging i got about 30 min of roaming with Rovio ...after you patch one problem another one comes along. Like everybody else who wanted more light for the camera i decided i wanna get the headlight attachment( ordered from robotshop) after a week of waiting for the headlights finaly they arrived ( all this time Rovio it' s fone and well charging as it should and realy holding up well the charge...about 1-1/2 hr of roaming) . I install the headlight and smoke and burned smell comes out of rovio...i disconnected the battery in time so it didn't died. After reading all the threads arround the website and seeing that i am not the only one having this problem i inspected what could be the problem of course it was the polarity of the headlight that goes back to rovio... I don't wanna wait for a replace so i decide to do some soldering... Finnaly my rovio charges fine and has a nifty headlight wich acctually improves the quality of the video in dark places really good. After about one hr of messing arround in dark spots in my house i decide i wanna go a little further with the battery and see how much it lasts off dock with the headlights on ...about an hr then died. I gab Rovio and place him back on the charging dock after 12 hrs or so i wanna give it a little spin, after 2 inches thr blue lights go off and shuts down. I search a little more and decide to go with a little more kick at the battery so i order a 5000mah 5 cell . Meanwile i have no pation and really i m getting frustated and go for the direct charging of the 3000mah battery( new one that just wouldn't charge anymore) two wires the battey and the facrory charger of rovio... I hook it up play two maps of Killzone , i get back to the battery ( really hot-just in time to get it out) hooked up to the rovio, gave it a spin and voila a miracle just happened the battery is as good as new....so far i played for about a 1/2 hr went down to 2 lines and decided to send rovio to his dock . Sorry for the long story but i felt like sharing this with everybody since i got most of my tips from the forum. Thanks and do not give up on rovio it is a really cool sentry for the money.... Hopefully Rovio will work still in the morning.

Carey
Carey's picture
Well my replacement Rovio

Well my replacement Rovio power pack/charger finally showed up from WooWee a few days ago, after 4 months since I originally complained to them. I guess 3 months after they issued an RMA and they agreed to send me out a new one.

It was shipped in the same light duty 2 3/4" square cardboard box they are put in from the manufacturer with a label on it, and a small piece of clear desk tape holding it partially shut. No post date, so I can't say that it wasn't lost in the mail, or if WooWee takes 3 months to send it out after confirmation. But I can say they should have put it in a standard mailer, and it should not have taken 4 months. They also refused to tell me how they shipped it and stopped communicating with me after I complained I never received it.

But I'm one of the many people that replaced the charger with a Radio Shack style unit, and that works fine.

denodan
denodan's picture
To everyone with battery

To everyone with battery problems, there is a simple fix that may work, without the need for a Radio Shack power supply as long as your Wowee power supply works.

I had a replacment battery and power supply also, the battery did not hold a charge and my replacment power supply was still no good, but lucky I had a power supply from my broken Rovio that works.

Anyway here is a simple soultion that works.

http://www.robocommunity.com/forum/thread/17304/Battery-problem-solution...

QuadStack
QuadStack's picture
Hey all,

Hey all,

I got the problem fixed, at least on my end. I sent a couple emails to WowWee and they replied fast enough. Of course, they put the responsibility on the place that I bought the Rovio.

"Thank you for the receipt. Please exchange item at the point of purchase as the store will honor the warranty within the first 30 days."

Still, they responded really fast. The below explanation resolved my battery issue. It's been about a week now and my Rovio is roving around just fine for extended periods of time with no problems. If you don't want to deal with returns, exchanges, months of waiting than just follow the steps.

Now then, here's what I did:
1. Go to your local Radio Shack (or electronics store) and buy this: http://www.radioshack.com/product/index.jsp?productId=3875404 ... I know it's $40, but it's worth it.
2. THIS IS IMPORTANT: You need to buy a tip for this! The adapter alone doesn't come with one. Grab the adapter that came with your Rovio and go to Radio Shack and buy a Enercell Adaptaplug. The associate there will help you pick our the right one. They're $7.
3. When you get home, save your old adapter. Now, you'll see 4 settings on the new Radio Shack adapter. Set the Voltage to 9. Plug your Adaptplug Tip into the new Adapter and plug it into the wall. Connect the adapter to the charging station and put your Rovio on the charger. Let it sit overnight.

That should do it.

Good luck!
- Bill

Sparrow
Sparrow's picture
I've tried with the

I've tried with the radioshack adaptor, that didn't helped. The problem in my case is not the battery or the charger it's rovio itself i already asked for a replacement then i purchased another one from buy.com (119.00) i will wait for the new ine do some test with them and then return the first one. I have 4 batteries 6v 3000mah two of them 1 7.2 3300 mah and received another one 6v 5000mah. Two adaptors 8v and 9 v none of them charge the battery thru the dock. I even tried to charge rovio directly with no dock thru the belly connectors it doesen't work that' s how i reached the conclusion that it' s a problem with rovio itself. Anyway i have peak charger Also i have a battery mod 6 v cells 3300 mah let rovio with headlights attachment on and it lasts for 5 hrs . Then the 5 cell 6v 5000mah i get about 4.30 hrs to 5 hrs with 80% of usage of rovio. The blue pack that came with rovio only lasts for about 1.1/2 hr . So it's a pretty good upgrade. Now only if get it rovio tk charge on the dock .curently i am working on a php and java script website for rovio and looking to attach a second ip camera any sugestions for a small hd wifi camera?

chris75
chris75's picture
Agree, charger module inside

Agree, charger module inside Rovio is flawed it's not just Adapter / Battery quality / power, though getting better adapter / battery mitigates the issues.
I opened Rovio plugged in a Scope and recorded full charge / discharge/shutdown cycle.
It's obvious charging is stopped way before pack is really full,delta peak detection seems broken, also sustain charge is too weak to keep pack from discharging and reported charge values via API looks biased so Rovio may switch off whereas battery level is not critical.

I'll see if piggy backing some extra microcontroller may fix issues, but i need to reverse engineer a bit the power board to understand where all things are.

As for extra HW on Rovio, I'm thinking too adding another cam/wifi, currently looking at a boards like IGEPv2 Beagle Board + USB CAM. This has the advantage to run a Linux distro and eventually get some GPIO to fix (control) charger module.
Total price is around 200$. Problem is to get the board inside the case , I'm thinking about spreading the battery elements around and reusing battery slot.

Sparrow
Sparrow's picture
I've done a mod that give you

I've done a mod that give you space in the battery slot...u can break the cells down and realign them 3 on on side and 3 on the other connected thru a cabe between them and just a deans conecter on one side, and 3m velcro on both sides will hold 'em in place. I have to take a look at that board.... The battery pack of 6 u can get it at radioshack for a good price 24$ and we re talking about 6 cells at 3300mah , a total of 7.2 v. I allready can say that helps alot (longer life off the dock).

Sparrow
Sparrow's picture
Oh btw i received the new

Oh btw i received the new rovio yeSterday and send the other one back. I can tell you that this is from a different batch. I've notice that the camera is less grainy , the motors runs smoother and it' s a little more firm , the northstar beacon from the dock projects different spots on the sealing and there not that spreaded like last rovio this one doesen't make so much noise when roaming...and off course so far no battery isue.

chris75
chris75's picture
Thanks for the update on

Thanks for the update on battery slot reuse, I'll try this.

Do you see a model number or any code on new one?
This could indicate they may have done an update to the design and silently fixed some problems.

Sparrow
Sparrow's picture
24104ws It says on the back.

24104ws It says on the back. The other one can't remember but was different anyways for this one i paid 119 $ wich is a fair price i think. Now let's see what we can hack n' mod.

chris75
chris75's picture
Mine says only model 8033, so

Mine says only model 8033, so may be a new generation of Rovio.
Given price drop may be I should get a 2nd and use 1rst one for spare parts.

Anyway, I'll hack a bit more and have a look at firmware code old one is ok for this.
Thanks for the information.

MassiveOverkill
MassiveOverkill's picture
Sparrow said: 24104ws It says

Sparrow said: 24104ws It says on the back. The other one can't remember but was different anyways for this one i paid 119 $ wich is a fair price i think. Now let's see what we can hack n' mod.

I have model 25400WS and mine charges fine.  My charger puts out 8.0 volts at the terminal posts.   I did have to re-orient the disc magnets in the posts so that the posts became magnetic.  One of my transducers was bad from the getgo as my Rovio pulls to the left slightly.  It's done the spin of death once so far.  I got mine from Woot

 The camera quality rivals my Trendnet IP600W PTV security camera, at least in the daytime.

Sparrow
Sparrow's picture
Since you mention that board

Since you mention that board i am really thinking of implementing one to my rovio too. My only concern is that you will have to setup a videostreaming server on it ...since usb cameras are fairly small these ays you can easily use the space of the current camera . I would use the streaming separate then use the ecos just for movement since i have no virtualy lag on any connection(only for movement) the video latency is annoying. It's that what you have in mind? I am willing to participate at this project...

Joginder Ahuja
Joginder Ahuja's picture
WOW WOW WOW..... I thought

WOW WOW WOW..... I thought battery issue was with mine rovio only. If I had known about this problem I would have never never bought this damn rovio. Dont even last for 5 minutes.... and guess what I bought 2. Seems like I have to return them.

piberico
piberico's picture
I think you must try li-ion

I think you must try li-ion battery.
ni-me are not so good and needs full discharge & full charge each time.

chris75
chris75's picture
Sparrow said:

Sparrow said:

Since you mention that board i am really thinking of implementing one to my rovio too. My only concern is that you will have to setup a videostreaming server on it ...since usb cameras are fairly small these ays you can easily use the space of the current camera . I would use the streaming separate then use the ecos just for movement since i have no virtualy lag on any connection(only for movement) the video latency is annoying. It's that what you have in mind? I am willing to participate at this project...

I currently have the 'standart' BeagleBoard (http://beagleboard.org/) and it's powerfull enough to run a full Debian 5.0 ARM (Lenny), i've run cherookee webserver and it's amazingly fast (600+ Pages/sec over usbnet) no doubt it can run PHP too with more than decent performances.
As for streaming there are all the Debian packages for webcams + videolan so should be no issue ( used some on other ARM boards with Phillips USB CAM ).
Only problem is to fit the board in the case and handle the 100-500mA extra power needed, but if possible this will be Rovio on steroid regarding processing power.

I'm spending couple of hours per week hacking on this, so not really qualifies as a projectn, though I'll post anything usefull I may do or find and answer questions if I have answers.

Mensra
Mensra's picture
I too have had a problem my

I too have had a problem my Rovio battery life. When it is fully charged, it reads 6.82 volts, measured at the battery inside the compartment. When it shuts down for low voltage, it measures 6.2 volts-again measured at the battery inside the compartment. Keeping in mind that this battery pack consists 5-1.2 volt Nickel Metal Hydride cells assembled to a 6.0 V battery pack, it is obvious that it is charging correctly or even overcharging. For some reason the firmware/software controlling the cutoff point for shutting down is set too high. The runtime is consistent with the surface charge of the Nickle metal Hydride's as seen on a discharge curve. I do not know what voltage the microprocessor requires for proper operation, but it should shut off based on the discharge curve of a nickel metal hydride battery pack of approximately 5 V not 6.2 V. Wowee needs to either send us a more powerful battery pack coupled with updated firmware or, if the microprocessor can use a lower voltage, send us firmware updates which will not shut down the power until five volts is reached by the battery.

chris75
chris75's picture
I confirm Rovio shuts off and

I confirm Rovio shuts off and stop charges at levels which are not correct.

I found battery and main Rovio power are connected directly so when charger sends charge current it goes in both Battery / Rovio . Since Rovio drains 500ma and charger board has difficulties sending more than 800ma it seems only 300ma Max is available for Battery charge. Also charger may have hard time detect delta peak as Rovio CPU may 'agitate' battery voltage . Looks bad design to me.

I Hacked with 2 low voltage drop diodes so rovio board is directly fed by dock or battery , when docked battery is then free from Rovio board perturbation and board gets directly power from dock. Indeed now, Rovio sees 'battery' full when docked and charging apparently daesn't start.

So looks like Rovio firmware controls totally shutdown / charge / end of charge, i thought local charger board controller was more autonomous. So may be a software fix is feasible by making smarted measurement of levels, charge curve etc....

Kal-El
Kal-El's picture
So, I'm a new Rovio owner.

So, I'm a new Rovio owner. And yes, I'm in the same boat as many of you. Just got this one from buy.com and it too only has a few minutes of battery after a full charge attempt, and that's with the Radio Shack 9v 2.5amp charger. (Never even used the stock charger... followed the various forums' advice instead and used the RS one from the get-go.) Charged it 12 hours. Ran it. Immediately, down a bar. 5 minutes or less later, down another one or two bars. It's down to one (it's last) bar in just a few minutes past that. Tried this overnight charging a few times. And just today, tried charging for 5 hours, and it went from full to low battery flashing in just a few minutes. Again, that's with the 9v 2.5amp charger.

(Interestingly, when it's flashing low battery and complaining through the browser about low battery, I can still drive it around for several more minutes. One evening, it took me 10 minutes to get it to run out of juice while it's on low battery so that I can watch it autodock. By the way, autodocking works great when battery's low. Just autodocks a lot, because battery is low a lot!)

So, I'm still very confused, after reading all these posts, as to how some people are able to get lots of life out of the battery? What am I doing wrong? Please help!

I need some advice... is this a defective battery? Defective charger? Defective Rovio? Is contacting Wowwee going to get me anywhere to getting this resolved. Some of yours have charging issues, and some do not.

Other than the battery issue, this is a great unit. Runs well. Docks well. Even the camera is ok enough. I'm just really, really bummed that I don't have a battery solution. And, I really don't want to have to return the unit if there is some way to get it working.

Someone earlier mentioned buying 6 cells at 3300mah , a total of 7.2 v, from radio shack. So, I assume they're all 1.2v each. But, is the 3300mah per battery or for all 6 batteries tied together? Do you know which radio shack part number those batteries are? The one's I saw at the shack were 2500mah. And is there a good tutorial of how to a) tie them all together and b) build the connector for the final pack?

Of course, this is assuming my stock battery pack is bad and the the charger is working. Will the new batteries help? How can a lay person test this (the old batteries, the charger, etc.?

I'd be happy to try the new battery thing, try anything, to keep my rovio as opposed to returning it. 15 minutes of it in action is just not going to work here... even though I really love Rovio's capabilities. (Heck, I even got it to work from my mobile phone on the local wireless!)

Thanks in advance!

Kal

hcubeh
hcubeh's picture
I just recently purchased a

I just recently purchased a rovio and I can't charge it as well. I replaced the charger with a radio shack charger, but still my rovio can't charge. I then went to the local r/c shop and ask them to charge the battery with a r/c charger and the battery charges fine, so I confirmed the problem is with rovio itself. I am very interested as how chris75 you dealed with the problem with voltage dropping diode, perhaps you can share? Thank you

denodan
denodan's picture
You may not need a RS charger

You may not need a RS charger if your charger is going fine, do what I did to get a battery going right. I had a battery that lasted 5 mins, did no get a new charger and now my battery lasts around 80-90 mins, search for the battery soluion. It's easy, it works and don't need a new charger if yours is ok. Just takes time, do a search here under denodan.

robochef
robochef's picture
From what I see this problem

From what I see this problem has been going on since 2008. I just purchased a Rovio with this same problem. WowWee cannot claim to be a responsive company with a significant problem like this going on for so long. Are they going out of business?

hcubeh
hcubeh's picture
Tried the redock your rovio

Tried the redock your rovio every other hour trick, but my battery never charge beyond 6.7v. Using a dedicated r/c charger, the battery can be charged to 7.5v, at this voltage, rovio lasts more than an hour.-
+

denodan
denodan's picture
Don't do that, let it

Don't do that, let it recharge, so the blue lights pulse, when it stops take it off and place it on the docking station again, will pulse, then do it again, keep this up for several hours, take if off then let it run donw totally till the blue lights out, then repeat. Eventually you will trick the battery into holding a full charge again.

Kal-El
Kal-El's picture
Denodan, after the blue

Denodan, after the blue lights stop pulsing and I remove it from the dock, how long should I wait before putting it back onto the dock?

Also, should I be checking what the interface's battery meter is telling me when I take it off the dock? (In other words, when the pulsing stops, should I check to see if the battery meter is showing full battery and not in charging mode before removing it from the dock and putting it back on?)

Still a bit confused about how you're able to trick the battery if it's a NiMH battery and supposedly doesn't have a memory.

cowboyctx
cowboyctx's picture
Just run Rovio Commander II

Just run Rovio Commander II on your PC. Select, Settings, Options Charge Mode On (Time in Minutes) and set it for 45. Leave like this all day(over 8 hours). It will be charged after that.

denodan
denodan's picture
Kal-El said: Denodan, after

Kal-El said: Denodan, after the blue lights stop pulsing and I remove it from the dock, how long should I wait before putting it back onto the dock? Also, should I be checking what the interface's battery meter is telling me when I take it off the dock? (In other words, when the pulsing stops, should I check to see if the battery meter is showing full battery and not in charging mode before removing it from the dock and putting it back on?) Still a bit confused about how you're able to trick the battery if it's a NiMH battery and supposedly doesn't have a memory.

Put it stright back on as soon as the pulsing stops, flatten the battery also a couple of times till the blue lights go right out alltogether.

 the batteries can develop a memory, which effect, which is why with a laptop, etc they say discharge them completely once a month if you use your power supply a lot.

It may or may not work for you, but did for me. My battery lasted on 5 mins, then ended up 12 or so mins, then 15, etc.  Now lasts about 80-90 mins on a full charge, so two good batteries now.

Kal-El
Kal-El's picture
Denodan, I'm giving it a try

Denodan, I'm giving it a try today. Last night I let it discharge and the battery read 5.89v when it was done when I checked this morning. Put it on the charger this morning, so, after 6-8 hours, the pulsing just stopped. Did a quick reading on the battery pack with a multimeter a moment ago. Read 6.56v. Clearly, we're not near 7.2v yet.

(Should the batteries read 7.2v when fully charged? I keep reading that that's a good target voltage.)

So, I immediately put rovio back on the charger, and it's pulsing again. Will check the battery voltage after that. (By the way, a reading of the dock's contacts show it is is putting out 9v using the RS charger.)

Denodan, how many more of the pulsing/then-off-the-charger/then-on-the-charger attempts should I do before I try to flatten the battery? Or should I flatten it after this recharge?

I'm still wondering how others are getting more than 15 minutes out-of-the-box. If it's a defect in some part in mine and not others, I'd like to get it corrected.

elfman
elfman's picture
Thanks to Cowboyctx for

Thanks to Cowboyctx for solving my battery issues!!

I did what he said in the post above, and I've gone from 5-10 minutes to well over an hour of time on the battery.

I downloaded Rovio Commander II, went to Settings->Options, and set the 'Charging Mode On' with a reset time of 15 minutes.

I left it on overnight, and then tested it this afternoon. The battery seems be fully charged, and performance is greatly improved!

I ran it around for about half an hour, then let it sit for another half hour, and the battery is still reading 75%.

I'm guessing the batteries are just fine.

Instead, the charger circuit cuts out too soon, never giving the batteries the deep charge they need after being in storage for so long.

Wowwee should take a tip from Rovio Commander II, and add a 'backup' charging feature to their next firmware release.

It would save them a lot of money in Customer Support. Wink

 

cowboyctx
cowboyctx's picture
Glad to hear it worked for

Glad to hear it worked for you. I set mine at 45 minutes and seems to work for me. But if 15 works for you then great. Just make sure your battery is not over heating during the charging process.

hcubeh
hcubeh's picture
I was thinking, if the

I was thinking, if the charger board is only capable of sending 300ma to the battery to charge it why does wowwee bother to include a 8v 2.6a dc adapter? They could use a lesser quality dc adapter, something like 8v 1000ma adapter, it would be cheaper. Maybe the charger is broken and that's why it can only charge the battery at 300mah

Kal-El
Kal-El's picture
Cowboyctx, if the battery is

Cowboyctx, if the battery is overheating during the charge phase, what could be causing that?

How cool should the battery be during charging?

Kal-El
Kal-El's picture
Also, Cowboyctx, with your

Also, Cowboyctx, with your software, do rovio's batteries need to be drained completely before trying the method you mention in your post?

cowboyctx
cowboyctx's picture
I am not a battery expert nor

I am not a battery expert nor do I claim to know anything about workings of the charging circuit of the Rovio. I just know that my program has been running over a year on my two Rovio's and I have not had the issues that everyone else has. I do not run Rovio Commander everyday to charge my batteries nor do I do a complete drain of the batteries (though that should not hurt them). The software only makes the Rovio reverse every x number of minutes to reactivate the charging routine on the Rovio, basically what Denodan is doing manually. If you are going to use Rovio Commander to try charging your Rovio I would start with 45 minutes and run it overnight and see if that helps. Again I have used it for over a year and had no issues with the Rovio, Battery, docking station or charger. USE at you own RISK.

Kal-El
Kal-El's picture
Denodan, in trying your

Denodan, in trying your method of taking it off the charger after the pulsing stopped and then putting it back on the charger, after a while, the battery got extremely hot (and it was still pulsing.)

Cowboyctx, which adapter are you using? The stock one? or the RS 9v one?

cowboyctx
cowboyctx's picture
I have both. I don't notice

I have both. I don't notice much difference between them. I do think the RS9v is better though.

Kal-El
Kal-El's picture
So, at this point, I've

So, at this point, I've trying the recharge-after-pulsing-stopped method, but it seems to have overheated the battery that way. I mean really overheated. Very hot to the touch. I had to remove it from rovio to cool down.

Why do you suppose that happened? (I was using the RS 9v power supply as I mentioned in an earlier post.)

With the overheated battery cooled down now, I started rovio up. Within 2 minutes, I was down to one bar, about out of power. If the battery isn't ruined from the overheating, I'll give rovio commander II a try. I'm also switching back to the stock power supply.

elfman
elfman's picture
cowboyctx said:

cowboyctx said:

Glad to hear it worked for you.

I set mine at 45 minutes and seems to
work for me.

But if 15 works for you then great.

Just make sure your
battery is not over heating during the charging process.

------------------------------------------------------------------------------------------------------

 Good point about overheating.

 I went for 15 minutes just to make sure it got a full charge overnight.

 Now that the battery is behaving properly, I'll scale back the charging.

 Thanks again for your work on a 3rd party solution!

P.S. After one night of a full charge, I got about 2.5 hrs of roaming time. (~40 minutes of random roaming, the rest stationary. Streaming video for the duration.)

P.P.S. I'm using the stock adapter, and didn't notice any sort of overheating. I'm concerned that people using higher voltage chargers should consider dropping back to the stock charger when using Rovio Commander II to charge the battery.

Kal-El
Kal-El's picture
Cowboyctx, a couple more

Cowboyctx, a couple more questions... I'm giving Rovio Commander II a try. And I set up the "charge mode on" as you described. So, rovio has been docked by your software and is now charging. (I'll leave it charging until tomorrow morning.) Should I be leaving your software up and running during the charging process? I assume so. Just want to doublecheck that I still need your sw running overnight.

This means that while on the dock and charging, rovio will still be connected via wireless and the camera will still be running. Is that correct? Will that make it tougher to charge rovio with the camera and wireless still active while charging?

cowboyctx
cowboyctx's picture
Yes, leave the Rovio

Yes, leave the Rovio Commander running. don't worry abut the cam and wireless....

jgeidl
jgeidl's picture
Just so you know, the problem

Just so you know, the problem still isn't fixed. I got my Rovio a week ago,; won't hold a charge. Contacted WowWee and they replied that it sounded like I have a bad charger. Have not been able to get any further response from them even after asking for further clarification. Don't know if they were going to send a replacement of just telling me tough sh*t or what the deal is.

I will give it a week or so and then I think I will contact the State Attorney General's office. I have a very very lower tolerance level for companies that do business this way. Judging by all of the similar complaints here they can't very well say they aren't aware of the problem.

Jim

denodan
denodan's picture
How often you do it, will I

How often you do it, will I think very. I let mine discharge completely 3 times I think. Everytime it would pulse for around 20-30 and stop, take it off and put it on dock again.

If your voltage is going up then it's working. Don't try this with a 9volt Charger. I would imagine this is causing your battery to overheat. Get it to hot and will damage the battery.

I did not put mine on a multmeter, but if would be a good indicator if it's working, seems it is.

I use to time mine rather then use a multimeter. Kept doing it till I got 90 mins or so out of the battery. A combination if completely discharing and charging will fix it. You will know when it's fixed when it takes 3-4 hours before the pulsing stops. If it stops in 1/2 and hour or so it's not fixed.

But warn don't do this with a 9v charger. Rovio is not designed to charge with 9 volts, and if you have a bad battery cause either cause a fire or damage the battery if it gets to hot.

I was lucky. My replacment power supply was still no good. Lucky I had a broken Rovio, so had a speare power supply that works.

Kal-El
Kal-El's picture
Cowboyctx, I set your battery

Cowboyctx, I set your battery charge mode for 45 in Rovio Commander II. I kept rovio on the dock for 7.5 hours and used the stock power supply. At the 7.5 hour mark, the charger indicator on Rovio Commander II was stable (not indicating charging), but only sitting at half-way across your on-screen battery meter.

What does that mean when the battery meter is at half-way and not indicating charging is happening?

I took a multimeter reading and see that I went up to 6.7v (I was at 6.56v before when I was testing yesterday)

What do you suggest I do? Increase the charge mode number from 45? To what?

Note, even the stock web interface (yes I tested that too this morning when I took rovio off the dock) software showed I was down a bar immediately after leaving the dock. And it quickly dropped a couple of bars with rovio's moving.)

Basically, it's doing the same activity it was before trying the various methods... it's just dropping it's power very quickly. Suggestions?

cowboyctx
cowboyctx's picture
Maybe you need to drain the

Maybe you need to drain the power like denodan says to do and repeat the whole process over the next few days. You could have defective equipment too. Try the repeat process.

P.S. the battery indicator on Rovio Commander really only work when Rovio is running and then it is an average of your batteries power.

Pages