OUR NETWORK: TechLore Explore3DTV MyOpenRouter MediaSmart home TiVoCommunity See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 3016410.0
February 11, 2008 01:45 PM

Categories: Robosapien V1 & V2

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

SJEinTexas

Member
Joined: 02/11/2008

Has anyone on this forum been experiencing delays in getting a replacement RSV2 from WowWee?  My 12 year old son and I discovered that we had an RSV2 with defective wiring last December.  I called WowWee customer support and talked to Jason.  He seemed to be familiar with the problem and after telling him the serial number of our RSV2, told me that WowWee would send us a replacement.  So, on December 5th, 2007, we sent in the parts WowWee requested: the foot battery covers, remote control, arm wires, and pictures of the serial number and bad wiring.

On January 3rd, we got a message that a replacement RSV2 would be sent out on Friday, January 4th, so we were very happy.  Unfortunately, it was not sent on January 4th.  It was also not sent on the other dates that were later promised of January, 11th, 18th, and 25th.  Each time the date was delayed, the story changed (I could give details of each of the stories, but it would be a long, long post).  The current story is that WowWee customer support is waiting on a new shipment of RSV2s from Hong Kong because their current stock of replacements has been depleted by recent replacement shipments.

This brings up a number of concerns, such as, are there that many defective RSV2s out there that need to be replaced?  Or, is WowWee having trouble manufacturing new, non-defective RSV2s?

Anyone else have anything to add to this?

Thanks.

   

Discussion:    Add a Comment | Comments 16-30 of 115 | Latest Comment | « Previous 1 2 3 4 5 6 7 8 Next »

March 3, 2008 10:30 AM

JMDickson said: Well, mine showed up today! Sady this one doesn't walk near as well as the original one did, but on the upside it does have the targeting feature on the remote that I thought was removed from all the newer units.

Can you please give me the production code number found on the white sticker located in the remote controller- It should be a set of numbers followed by letters.

Thanks,

Gale Y 

March 3, 2008 10:32 AM

   Wow Wee do not give a  .... it has been bought with 65 mil $ to produce new products for better deals not to replace old ones and loose money ... So I gues we have to wait for the new investitors to recover  the investment and then ... MAYBE ... we'll se some real robots !

Horia Pernea
http://www.roboticage.eu

March 3, 2008 10:54 AM

I think that Gale's presence in, and attention to, this thread shows that WowWee does care.

Hopefully she will be able to sort this out for the people who still have problems with manufacturing defects in their RSV2. 

ScottE -- collecting and building robots for 40 years - details in profile

March 3, 2008 5:15 PM

The production code (from the controller) is 34607WS

March 3, 2008 5:39 PM

SJEinTexas said:
JMDickson said: Well, all is not rosy.   This replacement robot will not open it's hands.  One other strange thing... It had a strip of orange cloth tied around one of the arm cables???  Wierd.
Wow (not WowWee)!  I wasn't going to post anything on this yet, but we just got the replacement robot on Friday.  After only about one hour of play on Friday night (after an hour of un-packaging, of course) and about on hour more on Saturday morning, we heard a "POP!" and now the left hand won't open and the right hand won't close!  And when I say "play", I mean careful, gentle, thankful-that-we-have-a-working-RSV2-that-doesn't-say-brain-batteries-low-all-the-time "play".  A couple times, I even stopped the play and inspected the batteries and found that, yes, they were NOT hot - not even warm!  We were in heaven!  Then the "POP!".  Now, the wondering: what should we do?  At this point, I figure the best thing to do is to call WowWee support on Monday morning and see what they have to say about this.  I'll keep you all posted.
Just to folllowup on this, I did call WowWee support on Monday morning, and after providing the production code for the replacement RSV2, they said they would send us another new one to replace the replacement.  All I can say at this point is that, although there have been some bumps in the road these past three months in dealing with these RSV2 issues, WowWee really seems to be trying to get this situation corrected in the best, consumer friendly manner possible right now.  So I would like to commend them and thank them.  If the new replacement works well, we'll be WowWee customers for life.

June 14, 2008 11:47 AM

I get my RSV2 1 1/2 years ago from Sharper Image. I played with it for a week and then not used it for a year. (I removed tha batteries).
When I wantd to use it again after a year with fresh batteries I always get the message 'Brain Bateries dead - powering down'
Do I have a faulty unit as well? - Where do I look up the Serial Number?

Thank you for your help

Michael

June 14, 2008 12:08 PM

Wow Wee removed the targeting feature?! I guess that makes my "new" V2 a old-in-box V2. (I got my V2 on clearence at TRU this spring.)

And if you need any replacement parts, ask Milw, because my V2 had a broken axel right out of the box, and Milw replaced it.

June 14, 2008 9:31 PM

Hi Michael,

Can you please contact our customer service department directly(customersupport@wowwee.com), or enter this problem into our customer support page from our web site www.wowwee.com and someone will contact you. You can find the production code number in the remote controller or foot of the RSV2. It is a white stocker with numbers followed by letters.

We will do all we can to help resolve this problem.


Regards,
Gale
WowWee Canada Inc.

September 19, 2008 12:44 AM updated: September 19, 2008 6:42 PM

Gale, Thank you so much for working with us! I also had the crumbling wire issue with my RSV2. I recieved instructions as to what to send back to wowwee. I recieved a phone call from wowwee support last Friday 9/12/08 requesting confirmation on my mailing address. That was pretty quick!

9/19/2008 I recieved my new RSV2 today!

October 21, 2008 4:54 PM

My unit is dead even after multiple battery replacement. Serial number is 31205WSHA. I have not opened it up. Is this covered by the replacement program?

October 21, 2008 5:38 PM

Hi Mark,

Please contact our customer service 1-800-310-3033 (U.S. and Canada).
They will ask you a few questions regarding your unit and where it was purchased.

If you have a copy of your purchase receipt that will be helpful too.

I will follow your case with customer service as well.

Regards,
Gale Y

November 1, 2008 1:24 PM updated: November 1, 2008 1:32 PM

Hi Gale, I also have that darn wiring insulation problem. I posted my problem on you support page on the website. I bought my robot in South Africa, so I hope that it is not a problem. It says on the box warranty void if sold in the USA and Canada. So it was NOT sold there, so I presume it is valid? I had the robot only 2 days or so when it died. On opening it one could clearing see the wire insulation crumbled off - never seen anything that bad before!!

Please could you follow up my support query. I really do appreciate what you have done for others, and hope you can help me too.

Many, many thanks.

View unverified member's comment - posted by Garould

January 21, 2010 1:09 AM

*** Deleted By Moderator ***


January 21, 2010 1:12 AM

*** Deleted By Moderator ***


Discussion:    Add a Comment | Back to Top | Comments 16-30 of 115 | Latest Comment | « Previous 1 2 3 4 5 6 7 8 Next »

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window